Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Empire Total War (+Steam) Port Forwarding


  • Please log in to reply

#1
Batemo

Batemo

    Member

  • Member
  • PipPip
  • 32 posts
Hey guys, I bought Empire Total War recently and I am having trouble playing online; not being able to join most, if not all of the games online.

I keep getting the error "Failed to connect: No response from the host"

I used this guide: http://www.portforwa...team_Client.htm but when adding the custom service there are 4 boxes to put the IP in, and the first three have [192].[168].[1].[___].

It is asking me to put numbers into the fourth box, but I don't know what to enter.

Could someone walk me through how to set up the port forwarding properly?
  • 0

Advertisements


#2
Belinrahs

Belinrahs

    Member

  • Member
  • PipPipPip
  • 248 posts
hello Batemo

you are looking for a static IP address which you must set then enter into those boxes. PortForward is an excellent site and also has a guide on configuring a Static IP address. Here you go: http://www.portforwa...g/static-xp.htm

Let me know if you have questions
  • 0

#3
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
I've followed those guide things multiple times, but it doesn't seem to work.

I don't know what I'm doing wrong.

:)
  • 0

#4
Belinrahs

Belinrahs

    Member

  • Member
  • PipPipPip
  • 248 posts
It looks like the port forward guide you were using was the the Steam client, not the game, which uses different ports. Are you using a firewall? If so, turn that off. Having the firewall off, does the game work? If not, connect your computer directly to your Internet modem and try the game. Does it work now? Let me know.
  • 0

#5
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
I turned the firewall off before, that doesn't work.

I plugged the modem directly into my PC and I managed to join a game then.
  • 0

#6
Belinrahs

Belinrahs

    Member

  • Member
  • PipPipPip
  • 248 posts
Can you check to see if the following options are on at your router site (192.168.1.1)

-NAT
-UPnP
-DMZ
-Firewall

let me know
  • 0

#7
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
UPnP is on.

I don't know where on the Router's UI I check for the other things.
  • 0

#8
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
Hang on, I've just been sifting through the UI and found a page.

WAN Setup

[X] Connect automatically as required

[_] Disable SPI Firewall

[_] Default DMZ Server [192].[168].[1].[0]

[_] Respond to Ping on Internet Port

MTU Size in Bytes [1500]

Edited by Batemo, 21 April 2009 - 06:45 AM.

  • 0

#9
Belinrahs

Belinrahs

    Member

  • Member
  • PipPipPip
  • 248 posts
Alright I have a new idea, this might do it because I can't find what ports your game uses.

1. First make sure you are directly connected to the modem. Make sure everything is closed on your computer, then open the game, connect to a server and get in the game.
2. Now, press ALT + TAB to minimize the game. Go to Start > Run and type cmd and click OK.
3. Type netstat and press Enter.
4. Reply with all of the results of netstat.

Edited by Belinrahs, 21 April 2009 - 08:46 AM.

  • 0

#10
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
I've not been able to find the ports neither, I've googled just about everything I can think of xD

I'll go do that now, and reply back here.
  • 0

Advertisements


#11
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
Just plugged modem directly into the PC and it wasnt connecting to the internet.

I restarted the modem and the PC - still not connecting.

I changed ethernet cables - still not connecting.

Now I'm back running through the router
  • 0

#12
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
Proto: Local Address: Foreign Address: State:
TCP 127.0.0.1:27015 Batemo-PC:27015 Established
TCP 127.0.0.1:49181 Batemo-PC:49181 Established
  • 0

#13
Belinrahs

Belinrahs

    Member

  • Member
  • PipPipPip
  • 248 posts
And that was while connected to a Empire: Total War server? :) Still worth a try I bet -- hoping that the ports are the same across all of the servers.

Make sure your PC is set to a Static IP. You will need to know what the Static IP is! If you do not know it for sure, go to Start > Run and type cmd then click OK. In the Command Prompt that appears, type ipconfig /all and press Enter. You need the number under IP Address for the network card that connects you to the internet.

Then go to the Netgear router management page. Click Port Forwarding / Port Triggering and you should see this
Posted Image

Click Add Custom Service

Under Service Name put TotalWar1
Under Service Type select TCP
Under Starting Port put 27015
Under Ending Port put 27015
Under Server IP Address put the Static IP address for your computer I mentioned earlier

Click Apply.

We need to do this again for a second port.

Click Add Custom Service

Under Service Name put TotalWar2
Under Service Type select TCP
Under Starting Port put 49181
Under Ending Port put 49181
Under Server IP Address put the Static IP address for your computer I mentioned earlier

Click Apply.

Finally, after all is applied, we'll do this for good measure. Unplug your modem, then unplug the router. Now, wait about 15 seconds. After about that much time, reconnect the modem and reconnect the router. Wait about 30 seconds to 1 minute for everything to settle, then attempt a successful connection to an Empire: Total War server through your router. If this connection does NOT work through your firewall (should you have one installed/activated), deactivate the firewall and attempt connection.

Reply with the results of everything! If it does not work with the firewall ON but it does work with the firewall OFF, please tell me what firewall you have installed.

I'm hardly out of ideas -- we'll get this resolved.

Edited by Belinrahs, 21 April 2009 - 11:52 AM.

  • 0

#14
Batemo

Batemo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 32 posts
I didn't know I had to be connected to a MP server, I just thought I had to be on the game, as it runs through Steam which requires me to be online.

Anywho, I did the netstat thing while I was hosting a game, and got these results:

Posted Image
  • 0

#15
Belinrahs

Belinrahs

    Member

  • Member
  • PipPipPip
  • 248 posts
Are you the only person on the router?

Are you using a firewall? If so, which one?

Also if so, is there a difference in whether the game works when the firewall is on or off?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP