Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

lsass.exe Failed to Initialize -> Repair -> More Issues (XP)


  • Please log in to reply

#1
Ian505

Ian505

    New Member

  • Member
  • Pip
  • 3 posts
Hello all,
I am having a lot of trouble with this Dell Latitude D630 laptop (running XP SP3 Home) I am fixing for a neighbor. The problem is the machine won't boot properly. Just prior to the logon screen being displayed, an alert appears with the following message: (note: typed from memory, may not be formatted exactly as below)

lsass.exe The application failed to initialize properly (0xc0000005). Press ok to terminate the program.


-----Below is most everything I've done to this machine and what I know about it-----

The story is one of the children of the owner was browsing (of all things) the WWE website, when all the sudden the antivirus software (avast! Professional) went berserk, with some 5 new alerts every second. (Each of these alerts mean the malicious application was stopped, not an alert that one was found.) Because they couldn't stem the flow, and the computer was locking up, they did a hard shutdown.

Upon reboot, the above error appeared. Pressing ok gets rid of the message, but after that the boot appears to have hung, displaying only a black background. Pressing Ctrl-Alt-Del yields no results. The only option is a hard shutdown and reboot, resulting in the same error. YAY!

When I received the machine, I verified there was a problem (and there was- exactly as described above) and proceeded to search the internet for a solution. 80-90% of all the websites I found said the laptop was a victim of the Sasser worm. So I compiled and burned a fresh copy of
UBCD4win and threw a grand total of 5 different antivirus programs at it. There were 2 trojans in the temporary files which I removed, along with all the other temporary files using a tool on the CD in order to expedite scanning. Neither of the trojans, however, were identified as the Sasser worm.

After the scan, I figured I would try to fix the problem by copying a replacement lsass.exe from the XP Pro disk I had. Before I tried that (which didn't work), however, I made a backup of the Windows partition (using and Roadkil's Disk Image) to an external USB drive.

More searching and prodding led me to believe it was a Windows registry error, correctable by an in-place Windows repair install. After the install, the lsass.exe error was gone, and logging in was possible.

Unfortunately, as soon as one logged into the system several error alerts appeared, each describing a missing dll or exe, each seeming to come from some application or another. An installer for the Roxio update manager prompts for a msi to install it from, and an EA Downloader (for a video game) prompts me to install Adobe's Flash Player. Notifications that looked like the security/firewall notifications from SP3 appeared in some corrupted language in my taskbar, and several icons in the control panel were either nonfunctional or displayed in that corrupt language. (All of the problem icons were related to the Windows Firewall, Windows Defender, and/or CardSpace) On top of all that, practically NOTHING had a working driver, not even the touchpad.

The first thing I did was go to the Dell website on my computer and download drivers according to the service tag on the problem machine. Since there wasn't a driver for the USB hub, the CD drive, or either the network or wired cards, I had to boot into the UBCD and copy the files from the external drive onto the local disk, reboot, and install from there.

I installed as many drivers as I could, but many gave me errors about needing to update the system, or not having Windows Installer. I got Windows installer the same way I got the driver and was able to get the video driver and the touchpad going, but that's about it. So I copied SP2 and SP3 redistributables to the local disk from the UBCD and installed those, which remedied the issues with the jibberish in the control panel and taskbar, as well as eliminated several error messages.

From there, I popped in my plug and play (thank goodness) PCMCIA wifi card and ran Windows Update, installing IE8 as the default IE6 wouldn't let me run Windows Update.

Which brings me to where I am now.

-I am still getting Roxio's install prompt, but cannot uninstall Roxio, among other things, due to the inability to find uninstallers or 'bad transforms'.
-I think my .Net Frameworks (1.1, 2.0, and 3.0) are all screwed beyond repair, and I cannot remove them even with Microsofts removal tool. I also cannot install them again as they say ithey're already installed, or they cannot find the MSI after extracting the files.
-I am backing up where I am, so I can go back to the original and get the drivers to bring to the new. Then I will actually have a CD drive.
--------------------------------------------

I know many of you are going to say it's not worth the trouble, but I feel like I am so close. What I would like to do is fix the problems one at a time. Hopefully, I will get the drivers necessary to get the whole system working. From there, I would like to fix the .net issues- which I think is one of the last major problems. Everything else can pretty much be reinstalled.

So if anybody knows of anything I can do to solve the .net problem, PLEASE let me know. I would really like to solve this, or at least know what caused it.
  • 0

Advertisements


#2
tyler kick you fase

tyler kick you fase

    Banned

  • Banned
  • PipPipPip
  • 220 posts
are you saying you have 5 antivirus on?
  • 0

#3
edge2022

edge2022

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,117 posts

but cannot uninstall Roxio

Does the Roxio uninstaller give you any errors? If so, which ones?

Try using Revo Uninstaller with Roxio.
http://www.revouninstaller.com/
If the Roxio uninstaller doesn't work, then Revo will scan for Roxio's folders, registry entries, and start menu items so that you can delete them manually.

What program are you using to backup your drive now? If you have a UBCD for Win then you should use Driveimage XML, as it is a default plugin for the UBCD.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP