Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

BITS Service not working after removing virus infection


  • Please log in to reply

#1
Thorqueh

Thorqueh

    New Member

  • Member
  • Pip
  • 1 posts
The virus had changed the ImagePath for the BITS service to
%fystemRoot%\system32\svchost.exe -k netsvcs

Google brings up many people with the same problem, and many having trouble actually changing the setting back, even using RegEdit.
( path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS )

In my case, RegEdit would display an error about writing the correct path to the register.

The trick that finnally did it was right-clicking the BITS service folder in RegEdit, choosing Properties and changing the permissions to full control for the Administrator user.

Hope this helps someone out there!

ps: this is caused by a virus, removing the virus first would be recommended. You may want to search the registry for other occurences of "fystemRoot"
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP