Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

pci bridge faulty?


  • Please log in to reply

#1
simon_c

simon_c

    New Member

  • Member
  • Pip
  • 2 posts
Have an odd error with a HP laptop - pavillion dv1000 (dv1145ea), XP Serivce Pack 3. A whole load of hardware devices in device manager have question marks against them and the error code 10 "device cannot start". When i change the view of device manager to view by connection all the devices that cannot work are attached to the PCI Bridge. There aren't any devices attached to the pci bridge that do work they all are unable to start. So far I have tried the following

1) updated system bios
2) formatted and done a fresh reinstall of windows xp with latest drivers from hp site (including intel chipset drivers).
3) tried various version of drivers on the pci bridge (microsoft and intel), none of which made a difference.

The laptop has the Intel 852/855 GM/GME chipset and the possible faulty pci-bridge is the 82801DBM (ICH4M).

Anything else i can try or is my best guess of faulty chipset correct? Would really like a second opinion before i throw it in the bin :)
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
sounds like you've diagnosed the issue correctly...i'm assuming that since you're talking about trashing the device that it's not under warranty right?
  • 0

#3
simon_c

simon_c

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Yes the laptop is way out of warranty. As the laptop is just used for internet and picking up email (and the usb ports all work) I am just going to purchase a cheap usb wireless card and continue to run it until it develops further issues.

Thanks for your reply, a 2nd opinion is always appreciated on weird problems like this.

Edited by simon_c, 30 July 2009 - 05:11 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP