Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

[SOLVED] PCI M-Audio Soundcard Suddenly Stopped Working

  • Please log in to reply




  • Member
  • PipPipPip
  • 202 posts
I make music with my computer and therefore the onboard sound card that came with my motherboard is disabled and I've installed a dedicated sound card instead. The soundcard I work with is an M-Audio Delta Series 2496 Audiophile PCI card. I've been using this card without problems for about 5 years.

Today the card seems to have stopped working and I suspect it has something to do with recent stuff I've been doing with my computer.

Here is stuff I did prior to my soundcard's failure to work. I have no idea which if any of these things are related to the problem or not. I also have know idea at what stage the sound stopped working.

- a friend came with an mp3 player (Creative ZEN Jukebox). He had some data on it (using it as a kind of external hard drive) which he wanted to transfer to my computer.

- I downloaded/installed the latest driver and plugged it (via USB) to my computer. The computer recognized the device, but for some odd reason it did not show all the data. We tried several things including re-downloading and re-installing the driver and installing a media player app by Creative but nothing worked. I uninstalled the driver and the Creative app.

(at this stage I remember my audio was fine, because I listened to some music. This was the last time I attempted to use audio before first noticing the problem)


- I realized that when installing the Creative app I had without noticing installed some bundled software that scans for outdated drivers. I uninstalled it. Then instead of trying to guess what other junk I had installed onto my computer or what leftover files there were hiding somewhere in my system - I decided to restore my system to a restore point I made (yesterday) just before. The system restore was successful.

- I have a 750 GB hard drive which used to be installed in my computer. Recently I removed it from the computer and placed it in a hard drive enclosure. Today I decided I want it back in my computer, so I opened the case and connected it in the slot where it was before, connected the cables and turned on the computer.

- I used a freeware application called EASEUS Partition Master Home Edition to change the letters of two hard drives (one internal and one external). I also changed their Drive Labels. None of these drives are system drives or contain any system files or folders. They only contain personal data.

- Then I used the same EASEUS software to create a new partition from unallocated space residing on the same drive where my c: partition is (system drive). Then I formatted this partition (with EASEUS Partition Master) and restarted the computer.

It is at this point when I first noticed there is no audio. I was trying to watch some streaming video on the internet and there was no sound. Then I tried playing some mp3 files on different media players - no sound.

I checked Device Manager and saw that my M-Audio device had a yellow icon with a black exclamation mark on it. My first thought was that I might have accidentally dislodged something when installing the hard drive, so I removed my soundcard from its PCI slot and plugged it back in. Turned computer back on and now I don't see my M-Audio device in Device Manager at all! No M-Audio and no exclamation point! I tried reinstalling the card to its slot once again, but no change.

This is the current situation. As part of my work depends on this audio card, this is a very important matter. I'd really appreciate help with this... THX!

Edited by adifrank, 05 December 2009 - 09:14 PM.

  • 0





  • Topic Starter
  • Member
  • PipPipPip
  • 202 posts
i solved it somehow myself. took out pci card again, reinstalled driver, inserted card in different pci slot. then it worked. thanks!
  • 0



    Grumpy Ol' MSgt (Ret.)

  • Retired Staff
  • 3,997 posts
  • MVP
Installing it in a different slot was a smart move as that forced the OS to actually re-install the driver, instead of basically verifying it was there.

Thanks for posting the followup.

BTW - I've been using M-Audio Revolution 7.1 card for years too - great card!
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP