Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Problems installing Directx9 and CIV IV

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I tried installing Civilization IV on my brand spanking new notebook and after successfully installing Directx9 from the disk, went on to install the game. It failed numerous times at various points and with different error messages, and when I looked around online I found that the version of Dx9 on the disk is problematic, so I tried downloading Dx9c....that couldn't fully install, so I tried the dx end-user runtime web installer and the install got nearly to the end before giving me an error saying to check the directx log. These are the last lines of that log:

01/15/10 11:38:14: dxupdate: CMDXInstall::Install(): Microsoft.DirectX.DirectDraw
01/15/10 11:38:14: dxupdate: CMDXInstall::Install(): InstallAssembly() failed, error = 0x80070005.
01/15/10 11:38:14: dxupdate: CMDXInstall::Install(): Unable to install Microsoft.DirectX.DirectDraw.dll.
01/15/10 11:38:14: dxupdate: DirectXUpdateInstallPlugIn(): MDXInstall::Install() failed.
01/15/10 11:38:14: dsetup32: CSetup::InstallPlugIn(): DirectXUpdateInstallPlugIn() failed.
01/15/10 11:38:14: dsetup32: CSetup::SetupForDirectX(): InstallPlugIn() failed.
01/15/10 11:38:14: dsetup32: start finalizing: phase: 223 - 223, total: 0 - 63
01/15/10 11:38:14: DXWSetup: DSetupCallback(): Phase = 3, Steps = 0
01/15/10 11:38:14: dsetup32: Installation ended with value -9 = Internal or unsupported error
01/15/10 11:38:45: DXWSetup: WM_APP_ENDINSTALL
01/15/10 11:38:45: DXWSetup: CDXWSetup::~CDXWSetup()
01/15/10 11:38:51: DXWSetup: CreatePropertySheet() returns -9.
01/15/10 11:38:52: DXWSetup: Deleted file C:\Windows\system32\directx\websetup\dsetup.dll.
01/15/10 11:38:52: DXWSetup: Deleted file C:\Windows\system32\directx\websetup\dsetup32.dll.

I was next going to try shutting off a program called Forefront based on someone's suggestion (if I have it installed), then maybe clean temp files and the registry and try again.

Help would be MUCH appreciated...and thanks in advance. Very frustrating.


Edit: disabled Avast and got Dx runtime installer installed. Retried CV IV and got to disk 2 when my autoplay asked what I wanted to do as an error popped up with the only information being "Catastrophic failure." That's not ominous at all.

Edit: Through searching my peers and I have uncovered major compatibility issues with Windows 7 that can be fixed by installing virtual computer Windows XP environment. I think this will fix the issue.

Edit: figured it out. I was installing from two different disk sets.

Edited by LinaJo, 16 January 2010 - 02:29 PM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP