Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Missing .dll files


  • Please log in to reply

#1
Strike Martel

Strike Martel

    Member

  • Member
  • PipPip
  • 70 posts
Hi guys, (Not sure if this should go in Malware)

Got a pretty serious issue here. Last night, various things were starting to happen. I couldn't open Sophos, mozilla, taskswitch, Windows MP wouldn't work etc...

So, I went into safemode, done a scan with Sophos and Malware Bytes. Sophos detected 22 things that it put into quarantine; MalwareBytes detected 3. I think they were rid of.

But, I appear to be missing the follow .dll files:
atl71.dll
cnvfat.dll
fmifs.dll
ureg.dll

They were all infected. I'm getting the msimg32.dll missing error, although I have downloaded that from dll-files and placed into the system32 folder. I also have atl71.dll

Windows File Protection is prompting me to restore the files with XP Pro Service Pack 3 Disc... what disc?
Also, I can't seem to register the files... "LoadLibrary failed" Specified module could not be found. I also get some dumb 0xc0000022 error or something.

Id 'be seriously appreciative if someone could assist me here.
Lucky for me, Opera still works.

PS: I also got PUA CmdNir, but I think that's because I used ComboFix sometime back - that's not malicious?
MapKrap-I
MalEmogen-Y
Mal EncPK-MK
They were all found too. I think Sophos quarantined them successfully. Malware detected a trojan.down... something, and two other things, but it said they were successfully removed.

Would downloading the sp3 cd iso and mounting it to daemon help?

[bleep] computer won't let me put msimg32.dll into the system32 folder now...
My browsing is starting to really slow now. I can't click add/remove programs. This is doing my head in.

Edited by Strike Martel, 15 March 2010 - 09:31 AM.

  • 0

Advertisements


#2
Strike Martel

Strike Martel

    Member

  • Topic Starter
  • Member
  • PipPip
  • 70 posts
removed log

Edited by Rorschach112, 15 March 2010 - 11:15 AM.

  • 0

#3
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
I suggest that you start a new topic in the Malware Removal and Spyware Removal area.

Before you start a new topic click on this link --> Malware and Spyware Cleaning Guide, Please read before starting a new topic. This will give you a few preparations to make, as well as instruction for posting your OTListIt2 log.

If you are still having problems after being given a clean bill of health from the malware expert, then please return to THIS thread and we will pursue other options to help you solve your current problem(s).
  • 0

#4
Strike Martel

Strike Martel

    Member

  • Topic Starter
  • Member
  • PipPip
  • 70 posts
Does this mean I have to wait for a long time, or, because I made a new topic in the malware forum where I was directed, I'm just wondering if I've lost my place in line so to speak? :)

I wouldn't usually pine but it's just so annoying the problem I've got, that's all. Nothing I do fixes it >_< But, I know about 3 day thing.
  • 0

#5
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts

But, I know about 3 day thing.


That's the way to do it. Those guys are very busy....
  • 0

#6
Strike Martel

Strike Martel

    Member

  • Topic Starter
  • Member
  • PipPip
  • 70 posts
Yeah. I didn't want to seem like I'm pressuring the guys. I just wasn't sure that posting in the wrong place "puts you in the back of the queue", as it were.

You guys have helped before :) Wonderful stuff!
  • 0

#7
John115

John115

    New Member

  • Member
  • Pip
  • 1 posts

Hi guys, (Not sure if this should go in Malware)

Got a pretty serious issue here. Last night, various things were starting to happen. I couldn't open Sophos, mozilla, taskswitch, Windows MP wouldn't work etc...

So, I went into safemode, done a scan with Sophos and Malware Bytes. Sophos detected 22 things that it put into quarantine; MalwareBytes detected 3. I think they were rid of.

But, I appear to be missing the follow .dll files:
atl71.dll
cnvfat.dll
fmifs.dll
ureg.dll

They were all infected. I'm getting the msimg32.dll missing error, although I have downloaded that from dll-files and placed into the system32 folder. I also have atl71.dll


Hey Strike Martel,

Have you tried to download all your missing files and put them in the c:\windows\system32 folder?

I've found them on http://down-dll.com
atl71.dll
cnvfat.dll
fmifs.dll
ureg.dll

I've check them all on virustotal.com and they are all clean.

Doing so should work (in theory)

I hope that will help.

Edited by John115, 26 March 2010 - 02:15 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP