Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Memory Problems with Firefox


  • Please log in to reply

#1
nessle

nessle

    Member

  • Member
  • PipPip
  • 20 posts
(I did try and get help at the Mozilla forums, but I only had one response, which directed me to an experimental memory recovery program. I suppose I can give that a try if it's the only option, but I'd be more comfortable if it wasn't experimental. Anyways, I've never had a problem getting help here, so hopefully someone will know what's wrong.)

Alright, since I updated Firefox with 3.6.1, I've been having a few problems. I'll occasionally lose tabs when I restart Firefox, which I've seen happen before I downloaded 3.5.1. The real problem however is the insane amounts of memory Firefox is using. I used to be able to leave Firefox open for a few days at least, usually a week, before the memory got too be a bit high and I had to restart. Now, I have to restart every five hours or so. The memory usage seems to constantly be building. As a test, I opened Firefox and let it sit for several hours, without using it. (I did leave my current tabs open.) The memory usage started out around 230 MB. By the time I came back it had jumped to 600+ MB.

This morning when I checked my computer it was running at 1.2 GB. Firefox said it was only running at 250 MB, but the second I closed it, my computer fell back to only 300 MB, which has me a bit considered I've got a virus connected with Firefox.

I do tend to keep around 40 or 50 tabs open, which I realize is a lot, but I've never had a problem with it in the past. I used to be able to keep 70+ tabs open without problems. All of my open tabs are to flash free sites. They're basically just text sites, without any graphics.

I've tried using Safe Mode and I'm still have problems.

I have no idea what's causing it. I tried using the Leak Monitor, but I honestly don't know enough about Firefox to tell what the problem is.

I've uninstalled and reinstalled 3.6.3, but I haven't seen any change. I also don't use any of the new themes.

I'm fairly certain that this only started happening with the 3.6.1 update, but I could be wrong. At this point I'm considering just downloading 3.5 again.

Windows XP
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.3 (.NET CLR 3.5.30729)
Plugins installed

* Shockwave Flash 10.0 r45
* npmnqmp 07103010
* Allows browsing on RealArcade sites with Mozilla browsers.
* npunagi2
* Adobe Acrobat Plug-In Version 7.00 for Netscape
* npdivxplayerplugin
* Office Plugin for Netscape Navigator
* DivX® Web Player
* 3D Life Player. For more information, visit the 3D Life Player web site.
* Adobe Shockwave for Director Netscape plug-in, version 10.2
* 6.0.12.46
* RealPlayer™ LiveConnect-Enabled Plug-In
* RealJukebox Netscape Plugin
* NPRuntime Script Plug-in Library for Java™ Deploy
* The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
* Default Plug-in
* Google Update
* iTunes Detector Plug-in
* Rhapsody Player Engine Plugin
* Java™ Platform SE binary
* Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
* Npdsplay dll
* DRM Store Netscape Plugin
* DRM Netscape Network Object

Edited by nessle, 07 April 2010 - 05:57 PM.

  • 0

Advertisements


#2
xblindx

xblindx

    Member

  • Member
  • PipPipPip
  • 132 posts
Try not using 40 or 50 tabs. Leave 1 or 2 open and see if it still happens.
  • 0

#3
phillipcorcoran

phillipcorcoran

    Member 1K

  • Member
  • PipPipPipPip
  • 1,293 posts
Well all I can say is that certainly isn't typical for the latest version. I've got 10 tabs open and it's using just 80MB, compared to 120MB using IE8 (10 tabs open). I'm a regular visitor to Mozilla's own forums and there's no mass-protest about Firefox's memory usage on there.

Edited by phillipcorcoran, 08 April 2010 - 02:40 PM.

  • 0

#4
nessle

nessle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Alright, once I closed all of my tabs I still had a bit of a memory drain, but no where near as bad. I started at about 80 MB with two tabs open and eventually it got up to 170 MB, but it hasn't gone beyond that, which is great.

Still, like I said before, I've never had this problem before. I used to be able to leave 70+ tabs open without any problems at all.

I guess I'll try reopening those tabs one at a time to see if one of them was causing the problem, but they were all from website I've used before. :)
  • 0

#5
xblindx

xblindx

    Member

  • Member
  • PipPipPip
  • 132 posts
I don't mean to sound offensive, but WHY would you need 70 tabs open?......Close them when you are done and it will save memory :)
  • 0

#6
nessle

nessle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I'm easily distra- Ooh, link.

Seriously though, I'm trying to cut back on my tab usage, but even with only six tabs open, Firefox is using 230 MB. It's not like I'm on any flash sites, so it's frustrating.

Edited by nessle, 09 April 2010 - 08:57 PM.

  • 0

#7
xblindx

xblindx

    Member

  • Member
  • PipPipPip
  • 132 posts
Firefox has always seemed to use a bit more memory than other browsers, but I've never had over maybe 10 tabs open at a time. I usually have around 4 open.
  • 0

#8
Lister192065

Lister192065

    Member

  • Member
  • PipPip
  • 61 posts
5 Tips To Reduce Mozilla Browsers Memory and Cache Usage

Everyone knows that Firefox is such a memory hog. Once you start to open up a few extra tabs, it starts to slow down your whole system, resulting in the familiar images below.
Posted Image
Posted Image
Fortunately, you can do something about it. Here are simple tips and tricks to reduce firefox memory and cache consumption.

These tips can be used with any Mozilla Based Browser, using either Windows or Linux

Tip 1: Reduce session history

browser.sessionhistory.max_entries determines the maximum number of pages in the browser’s session history, i.e. the maximum number of URLs you can traverse purely through the Back/Forward buttons. The Default value is 50.
We usually won’t surf more than 5 of the websites we previously surfed before, and there is really no need to store more than that in the session which can clog up memory as they grow.

1. Open Firefox
2. Type
about:config in the Firefox address bar
Posted Image
3. Press CTRL-F and search for
browser.sessionhistory.max_entries
4. Double click on the value 50 (or whatever value is there currently) and change it to something lower such as 5.
5. Restart Firefox.

For Firefox 1.5 and above, you can also look at another configuration variable browser.sessionhistory.max_total_viewers which also determines the maximum number of content viewers to cache for “bfcache” (fast back/forward navigation). Default value is -1 (calculate based on available memory).
Set it to 0 so that no pages will be stored in memory.
set it to a number such as 5 to store only 5 pages in memory.
more info here


Tip 2: Reduce memory usage when minimize

1. Start up Firefox
2. Type in
about:config in the address bar and hit Enter
3. Right click and choose New > Boolean
4. Type
config.trim_on_minimize in the pop-up box and hit Enter
5. Select True and hit Enter.
6. Restart Firefox

Tip 3: Fixed cache capacity OR Disable Cache Totally

Every time new page is loaded, Firefox will cache the page so it doesn’t need to load again to be redisplayed. By default, this setting is set to -1 for browser.cache.memory.capacity and to a number you specified in;
Tools -> Options -> Advanced -> Network / Cache for
browser.cache.disk.capacity

To fix your cache to a certain value:

*browser.cache.memory.enable and browser.cache.disk.enable needs to be True for this to work
1. Start up Firefox
2. Type
about:config in the address bar and hit Enter
3. Search for
browser.cache.memory.capacity and set a number in KB to use for the memory cache
(ie. 1024KB = 1MB).
4. Search for
browser.cache.disk.capacity and set a number in KB to use for the disk cache
(ie. 1024KB = 1MB).

To Disable the cache Totally

Set both browser.cache.memory.capacity and browser.cache.disk.capacity to 0.
Alternatively, you can also set
browser.cache.disk.enable and browser.cache.memory.enable to False.

Tip 4: Use less extension and themes

This is really a no brainer. Uninstall all firefox extensions and themes that you don’t use as they can cause Firefox to use more RAM. If you think that you might still need the extension in future but not using it currently, at least there’s an option to Disable it. Use only extensions that you usually use to cut down memory usage.

Always upgrade your extensions and themes to the latest version as they may fix the some problems leading to memory leaks. Firefox makes this quit easy as it now does the checking for you, all you need is to do is tick some checkboxes and your plugins and themes wil be updated.


Tip 5: Check Firefox Memory Usage

Type about:cache?device=memory in the address bar and hit Enter. Firefox will display your current number of entries, maximum storage size, storage in use and inactive storage.

There you have it. Happy browsing!

  • 1






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP