Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

vista won't open exe's

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hello all, very n00b so please be gentle...

It all started with (a) virus(es). Ave.exe, vista internet security, and a few others. I used an AVG tool recommended to me by a friend that is on a USB stick that I could boot to and run my scan to locate the infections that Symantec couldnt while the OS was up and running. AVG found three files: users/appdata/local/ave.exe, users/appdata/local/opera/opera/profile/cache4/opro5nqz, and windows/system32/drivers/iastor.sys.

Dummy me, I deleted all three not knowing that iastor would cause a world of trouble. I was unable to boot following the purge. No startup repair helped. Finally I was advised to change my SATA settings in BIOS to see if I could then boot. I changed the controller mode from AHCI to ATA after disabling the flash cache module. I was able to boot after I made those changes. But when I got vista booted, it seemed that vista forgot how to treat executables. I was asked what program to use to open rundll32.exe, what program to use to open the exe for a driver downloaded from dell to replace the iastor i deleted, even what to use to open firefox.exe. Just as a hunch I tried running a few things "as admin" from the context menu, which actually worked. I was able to extract the driver and replace the iastor file in system32. After doing that I went back into BIOS and changed back to AHCI. Boots like a champ now, but still doesnt know how to treat exes. Also noticed that when i try to acess task manager from right clicking the taskbar i get a "cannot be found" message, whereas if I ctrl-alt-del to open task manager it works fine. Also during this Vista installed 13 updates. And I just noticed sp1 was never successfully installed.

Anyone know how to help a fool?

Edited by ignignokt83, 29 April 2010 - 01:13 PM.

  • 0




    Sir SpamAlot

  • Retired Staff
  • 7,671 posts
I suggest you go to the Malware Forum and run all the steps located in the START HERE. These self-help tools will help you clean up 70% of problems on your own. If you are still having problems after doing the steps, then please post the requested logs in THAT forum. If you are unable to run and/or post the required logs, then post that in your initial post in the topic you create in that forum.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP