Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

WD Passport External Harddrive not recognized


  • Please log in to reply

#1
sannie

sannie

    Member

  • Member
  • PipPipPip
  • 154 posts
I needed to reformat my laptop and backed up important data on my external WD Passport.

After reformatting the laptop (Windows XP), it doesn't recognize the external harddrive anymore.

When I connect it to the laptop, the "safely remove hardware" icon appears in the system tray.

I can see the device in the device manager, but it won't show up in Windows Explorer.

I tried it on a different computer with the same result.

If I go into disc management, it shows the external hard drive as "disk1", but it doesn't show up in the upper half of the window with a drive letter assigned to it.

Any suggestions?

I was trying to reimport data onto my laptop, but now I can't get to it.

Thanks!
  • 0

Advertisements


#2
phillipcorcoran

phillipcorcoran

    Member 1K

  • Member
  • PipPipPipPip
  • 1,293 posts
Go back into "Disk Management".

Find the correct "ribbon" representing the Passport drive in the lower portion of the disk-management window.

Right-click that ribbon and choose "Change drive letter and paths" (I use Vista so yours may be slightly different).

Choose any spare drive letter and click 'OK'

Your Passport drive should now have a drive letter in 'My Computer'

Edited by phillipcorcoran, 03 May 2010 - 09:41 AM.

  • 0

#3
sannie

sannie

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 154 posts

Go back into "Disk Management".

Find the correct "ribbon" representing the Passport drive in the lower portion of the disk-management window.

Right-click that ribbon and choose "Change drive letter and paths" (I use Vista so yours may be slightly different).

Choose any spare drive letter and click 'OK'

Your Passport drive should now have a drive letter in 'My Computer'



It doesn't give me this option in the lower portion of the window. It just lists it as "disk 1" and I can look at properties, but not assign a letter to the drive.
  • 0

#4
phillipcorcoran

phillipcorcoran

    Member 1K

  • Member
  • PipPipPipPip
  • 1,293 posts
Is your current xp installation at the same service-pack level as it was previously (ie SP1, SP2 or SP3)? If not, you may have to update to the latest service pack. A 'vanilla' XP (no service packs) did have a recognition issue with some USB devices which was fixed with the service packs. SP3 was the final service-pack and that's the one you should install if possible - it includes all the updates and fixes which were in SP1 & SP2, plus a load of additional fixes.

So after a fresh xp install, you don't need to add all three service packs, just the final one.

Edited by phillipcorcoran, 04 May 2010 - 04:42 AM.

  • 0

#5
sannie

sannie

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 154 posts
Yeah, I have service pack 3... doesn't matter :)

Edited by sannie, 04 May 2010 - 08:22 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP