Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

GRUB DILEMNA


  • Please log in to reply

#1
Bald Patches

Bald Patches

    Member

  • Member
  • PipPip
  • 12 posts
I've just installed Ubuntu 10.04 after Mandriva on an external HD.

I have 8 OS's altogether and Grub handles the rest fine - but Mandriva wont list properly!!!

I've already tried the Super Grub Disc - to no avail.

I know that I just need to tweak a Grub file somewhere - but which one???

:) Any ideas?

Edited by Bald Patches, 01 June 2010 - 09:05 AM.

  • 0

Advertisements


#2
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,645 posts
The menu file is typically in /boot/grub and called menu.lst, but the name might have changed with grub2.
  • 0

#3
DaffyKantReed

DaffyKantReed

    Member

  • Member
  • PipPipPip
  • 485 posts
Type the following at the command line:

sudo update-grub2


Reboot the PC and see if Mandriva is listed. Ubuntu now uses Grub2 and editing menu.lst is no longer possible.
  • 0

#4
DaffyKantReed

DaffyKantReed

    Member

  • Member
  • PipPipPip
  • 485 posts
Also see:
http://ubuntuforums....d.php?t=1195275
  • 0

#5
Bald Patches

Bald Patches

    Member

  • Topic Starter
  • Member
  • PipPip
  • 12 posts
Thanks for the info guys - I'll tackle it over the weekend :)

Edited by Bald Patches, 04 June 2010 - 07:05 AM.

  • 0

#6
Bald Patches

Bald Patches

    Member

  • Topic Starter
  • Member
  • PipPip
  • 12 posts
Here's what worked thanks to a member on Ubuntu Forums:

I got the correct address from GParted as OS-Prober produced something totally confusing - there is no device.map file and my second drive changed to sdb after the first edit??? - I took out the “hd’s” - and just as I was getting ready to give up and shut down for the night Mandriva booted.

After numerous re-edits of 40_custom in etc/grub.d this is what finally worked:

menuentry "Mandriva 2010 (on /dev/sdb2)" {
insmod ext4
set root=
search --no-floppy --fs-uuid --set 9b8a9870-e1e0-4408-b694-465a3464744a
linux /boot/vmlinuz BOOT_IMAGE=linux root=LABEL=MANDRIVA root=UUID=9b8a9870-e1e0-4408-b694-465a3464744a splash=silent vga=788
initrd /boot/initrd.img
}

Where as what os-prober produces is:

menuentry "linux (on /dev/sdb2)" {
insmod ext2
set root='(hd1,2)'
search --no-floppy --fs-uuid --set 9b8a9870-e1e0-4408-b694-465a3464744a
linux /boot/vmlinuz BOOT_IMAGE=linux root=LABEL=MANDRIVA resume=UUID=81917bd1-ae88-4519-8774-345c41958c76 splash=silent vga=788
initrd (hd1,1)/boot/initrd.img
}
menuentry "linux-nonfb (on /dev/sdb2)" {
insmod ext2
set root='(hd1,2)'
search --no-floppy --fs-uuid --set 9b8a9870-e1e0-4408-b694-465a3464744a
linux /boot/vmlinuz BOOT_IMAGE=linux-nonfb root=LABEL=MANDRIVA resume=UUID=81917bd1-ae88-4519-8774-345c41958c76
initrd (hd1,1)/boot/initrd.img
}
menuentry "failsafe (on /dev/sdb2)" {
insmod ext2
set root='(hd1,2)'
search --no-floppy --fs-uuid --set 9b8a9870-e1e0-4408-b694-465a3464744a
linux /boot/vmlinuz BOOT_IMAGE=failsafe root=LABEL=MANDRIVA failsafe
initrd (hd1,1)/boot/initrd.img
}


I shall follow the rest of their advice and tidy up my boot menu and disable os-prober!!!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP