Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

First Timer having a bit of difficulty

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hey guys I just built my first pc (yay!) and i got it all up and running but im having troubles with speed and i dont think i should.. it took me over an hour just to load windows xp and i know that isnt right lol.. now my cpu is an Intel® Core™2 Duo CPU E8400 @ 3.00GHz, memory 2Gx2|ADATA AD3U1333B2G9, my video card is a zotac geforce 210 512 i think, i am using an old hard drive as well using IDE hookups and if it matters my hd is slave while my cdrom is master which im not sure how to fix yet haha so any advice on why its going so slow would be greatly appreciated
  • 0


Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
How big is your hard drive? And more to the point, how old is it? (there will be a manufacturing date on it)
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP