Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Auto sensing secondary master hard disk D:


  • Please log in to reply

#1
glaivekiddo

glaivekiddo

    New Member

  • Member
  • Pip
  • 4 posts
every once in a while when i boot my comp, i will get an error auto sensing secondary hard disk message. then i have to power it off and on again, again and again. until i get to boot into my windows.

i suspected it was a case of bad contact? but i opened up the cpu and clean up a lil bit, unplug and plug the contact wires back. i'm still getting the error. i asked in another forum, but i'm still not getting anywhere. =/

http://www.techsuppo...hd-problem.html

i want my comp to boot perfectly each time, not getting errors randomly. it's really frustrating. can anyone help me?

my computer is a dell XPS420 factory build.
intel core 2 quad q6600 2.4ghz
vista sp2
2x1gb necc dual channel ddr2 667mhz sdram
500gb sata hard drive (WDC) [partitioned into two drives]
256mb nvidia geforce 8600gts
on the psu: make - dell, model - L425P-00, dc output - 425W

i have never customly upgraded any hardware. any help is much appreciated, thanks
  • 0

Advertisements


#2
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
From what I understand you have only one Hard Disk (500gd Sata WDC) so your BIOS should only detect one HD. Even if partition for Windows (C: & D:) your BIOS only sees one HD and should not look for another HD.

What I would check is in your BIOS where you have your HD make sure that the secondary master is disable (if no Hard Disk connected to it) this way at boot it will not look for it (auto Sensing)

If that does not help try:

Check if it is not in Raid mode, might be the reason your BIOS is auto sensing for the second of the 2 HD needed in Raid mode (you only have one).

Hope that helps.
  • 0

#3
glaivekiddo

glaivekiddo

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
hi, thanks for the prompt reply. and i just booted. coming back from the bios.

here's my finding:

in the bios, when my hdd is detected, it will have its full name displayed under SATA-0 drive, if not it will be an "unknown" instead. same goes to the listing under the boot sequence. if it's detected, it will be listed, if not, "unknown"

and i cant seem to find the section concerning master or slave, primary or secondary

and my bios's raid mode is on auto detect, raid only if signed, otherwise ATA.
  • 0

#4
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
I took this information from the Manual of the Dell XPS 420.

On the setup screen go to the "Drives" section and set the SATA ports (SATA 0 through 4)to the
correct configuration (choices are ON, OFF or RAID ON). Hard Drives should be connected to sata port 0 or 1.

If your Hard Drive is on Sata port 0 set it to ON (not RAID ON) and any other Sata port to ON if they are used (DVD player), if some Sata ports are not use set them to OFF.
  • 0

#5
glaivekiddo

glaivekiddo

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
yeah. in the drives section, there are 5 sata ports, 0-4. however mine doesn't have the RAID ON option.

my harddrive is connected to port 0, and the setting is set to ON
port 1 and 2 are both of my dvd drives, they are set to ON as well.
port 3 and 4 are blank and thus, set to OFF


however, when ever i got the error and am in the setup, port 0's device will become "unknown" if i am in a potentially successful boot, port 0 will name my hdd, like WDC something, the full name of the harddrive

Edited by glaivekiddo, 26 June 2010 - 08:28 AM.

  • 0

#6
Alzeimer

Alzeimer

    Member 1K

  • Member
  • PipPipPipPip
  • 1,330 posts
Then it is either your sata wire, your sata port or your hard drive that is sometimes not sending the information at Boot time.

Try another sata wire,
Try putting your hard drive on sata port 1 and move your DVD to port 2 & 3
If none of those work test your hard drive by downloading from WDC the boot program for testing your drive

Also here is something to consider
In your manual they say that Port 0 & 1 should be for Hard Drives only and Port 2, 3 & 4 for DVD/cd-roms
Test it you never know

Edited by Alzeimer, 26 June 2010 - 03:02 PM.

  • 0

#7
glaivekiddo

glaivekiddo

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
hey, thanks for the continuing help.

i got a new sata cable, hooked it up, and at first it looks promising, but the old problem comes back

then, i changed the hdd to port 1, dvds to 2 and 3. looks promising at first, after a few boots, it came back again

after that, i changed it to port 0 again, with dvds ar port 2 and 3. it booted successfully again, i can only know what happens next the next time i reboot.

edit: it happened again this morning, with the hdd on port 0, dvds on 2 and 3. took me almost half an hour to get here. i've scanned my hdd with wdc's software, nothing's wrong with my hdd.

Edited by glaivekiddo, 28 June 2010 - 08:14 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP