Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Many Errors, Vista, Class Not Reg, Working on VISTA Acer Laptop


  • Please log in to reply

#1
stripesthegamer

stripesthegamer

    Member

  • Member
  • PipPip
  • 14 posts
Once again directed to Malware when it's a system file problem, but oh well...here I am. I have numerous Malware Cleaners on it...and they have done their thing...they come up empty handed now..MalwareBytes is just fine.

NOTES
Unable to Update
Unable to do System Restore
Unable to Install ANY Updates
Unable to Install SP2 (figured this would replace the currupt system files)
Unable to Repair Install, OEM install - FACTORY is not helpful
Unable to SFC Scan ... It scans and says it can't fix the errors (how lame is that)

Vista Home Premium
OEM Acer Laptop
Service Pack 2

Long story short, I've been working on a friends laptop for 4 hours now gaining nothing. I never noticed the problem before...It may of existed or may not of. I removed Norton (dling the remover from norton) and installed Avast, I noticed I kept getting security alerts for no firewall and antivirus, turns out I couldn't turn on firewall...so I figured some malware, sure enough didn't surprise me the PAID FOR Norton Internet Security had missed some stuff, and it had about 38 registry malware... (malwarebytes). This is not the problem though, the problem is, I can't turn on the Windows Firewall (although Defender appears to work flawlessly), I can't Update, when I try to open Avast Anti Virus it gives an error about side-to-side service, I can't install any M$ download. First I thought it was windows installer, didn't install. Then I tried registering the msiserver....(ms installer), still no luck. Then I tried installed SP2 over SP2 hoping to get the missing files replaced. (After attempting SFC Scannow, and it said it could not fix the files)

The main error I'm diagnosing now is stuff about CLASS NOT REGISTERED.
Secondary Error (when trying to install Visual C++ 2010 Redistributable Libraries) "The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed" <--I am unable to install it, and It
's runinng under services.msc
The current error - "REGDB_E_CLASSNOTREG(0x80040154)" <--Google this, gets me no where. I can't install any Microsoft programs to try and patch the bug. I can't repair because of OEM. I can't do a backup because System Restore doesn't work, I can't Create a new user because it doesn't ever open up after allowing control, the list goes on. Basically I need to tackle the problem at the source. Is it the Microsoft Installer not registering the installations? I thought it was a C++ Error that it lacked coding too, and never could install a redistributable.

Thanks for any help...
  • 0

Advertisements


#2
stripesthegamer

stripesthegamer

    Member

  • Topic Starter
  • Member
  • PipPip
  • 14 posts
Closed
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP