Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

IP conflicts


  • Please log in to reply

#1
JonF

JonF

    Member

  • Member
  • PipPip
  • 23 posts
I developed this problem this week on a system I have been running for about 2 years.

The problem is that I can only connect one computer to my home network at a time. I have a hardwired desktop and several wireless devices(2 laptops, nook, PS3). I can connect any of then to the system and get full internet access. However, if one computer is connected to the network and I try to connect a second, I get a Windows system error pop-up balloon saying that there is an IP conflict and I can not connect to the internet. The wireless connections are strong. When I assigned a static IP to my desktop, I could connect one wireless computer to the network but not a second.

All computers are running XP and set to automatically assign IP's.
I have a Motorola modem and a Linksys router.
I have tried turning off/on the power to the modem and router, but that did not fix the problem.

I know I could assign static IP's to my computer and PS3, but that is a work-around and does not really fix the problem.

Thank you for any help and I apologize if this problem has been addressed already in the fourm

Jon.F.
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Why is assigning static IPs not a fix to the problem?
All those devices will work with static IPs.
  • 0

#3
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
I agree with JonF assigning static IP address isn't really the best way to go. If the network was to expand then every other device would have to be setup manually aswell. It is a lot easier and less error prone to setup devices automatically unless you want specific devices to always have the same ip address for instance a file server.

Anyway, to try and answer your question JonF it would appear that your DHCP server built-in to your router is not working as intended. It would seem that every IP address being issued is the same and that is why you can't access the internet. I would check the settings for DHCP under your router configuration page. Also, if you wouldn't mind doing the following:

Go to start -> type cmd in the search box at the bottom (or click 'run' if using win. XP) -> hit enter ->type ipconfig /all -> print screen the full output -> paste it into paint or something -> save it and upload it.

Do this twice, first when only one computer is connected (and you can connect to the internet). Then connect another computer and ipconfig /all that aswell.

Thanks,
  • 0

#4
JonF

JonF

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Thank you both for your quick replies. To use a medical metaphor: Using static IP's treats the symptom but not the disease. Using static IP's will let my system work, but not the way it was originally intended.

Here is the output from "ipconfig /all" I ran it on my wired computer.

Connected to the internet This was done last night

Windows IP Configuration

Host Name . . . . . . . . . . . . : DC7NPWG1
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® 82566DM-2 Gigabit Network Connection
Physical Address. . . . . . . . . : 00-21-9B-33-EC-31
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.64
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::221:9bff:fe33:ec31%4
Default Gateway . . . . . . . . . : 192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DNS Servers . . . . . . . . . . . : 192.168.1.254
fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Lease Obtained. . . . . . . . . . : Friday, September 03, 2010 10:20:11 PM
Lease Expires . . . . . . . . . . : Saturday, September 04, 2010 10:20:11 PM

Tunnel adapter Teredo Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-3F-83-BB-2E-32-01
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 2001:0:4137:9e76:0:3f83:bb2e:3201
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%5
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : C0-A8-01-40
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.64%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1

NetBIOS over Tcpip. . . . . . . . : Disabled


Disconnected from the internet This was done this morning

Windows IP Configuration

Host Name . . . . . . . . . . . . : DC7NPWG1
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® 82566DM-2 Gigabit Network Connection
Physical Address. . . . . . . . . : 00-21-9B-33-EC-31
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
IP Address. . . . . . . . . . . . : fe80::221:9bff:fe33:ec31%4
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 255.255.255.255
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1

Tunnel adapter Teredo Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%5
Default Gateway . . . . . . . . . :

NetBIOS over Tcpip. . . . . . . . : Disabled
  • 0

#5
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
Ok, thanks for your reply. I can see the first connection has set itself up just fine but the second one is all wrong. In this case, the client has an IP address of 0.0.0.0—an invalid address—and the DHCP server is 255.255.255.255—a broadcast address. This means that the computer was searching for a DHCP server but failed to receive a IP address.

The official response from Microsoft is available here: http://support.microsoft.com/kb/822123

I've also been told the following: "This problem can occur after uninstalling Norton AntiVirus, which sets the DHCP service as depending on itself. It can also occur when the computer name of the client computer is too long. Make sure that all computer names in your network are no longer than 15 characters".


Further to this I would have to say look into your router settings to ensure the DHCP server is configured properly.

Thanks.
  • 0

#6
JonF

JonF

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
The problem seems to be in the router not my computers. I don't have Norton on any of mysystems
  • 0

#7
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
I would think it is your router's settings. Have you checked the DHCP settings under the router? If your unsure what to do post back with the make and model of your router and I'll see what I can do.
  • 0

#8
JonF

JonF

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
It is a Linksys WRT54G using firmware 8.2.03. It is currently set at automatic configuration - DHCP
  • 0

#9
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
I've had a quick look at a manual for a router called WRT54GL. From that I learnt that there should be a page called "Network Address Server Settings (DHCP)". There are various settings available on this page. You should use the following settings in my opinion:

DHCP Server: Enabled
Starting IP Address: 192.168.1.2
Maximum Number of DHCP Users: 50
Client Lease Time: 1440 minutes.

Change your router to these settings to see if this helps.
  • 0

#10
amw_drizz

amw_drizz

    Member

  • Member
  • PipPipPip
  • 329 posts
About how old is your current router? I have an old (3-4yrs old) motorola router from vonage that can't mange its own IP addresses anymore. So mabey look into getting a newer one. I would have gotten a newer one but I just tweaked my network so it has a different DHCP server and disabled it on the router.

Also when was the last time the firmware on the router was updated? And did it start acting up after the update? Since some updates may have messed up the DHCP server on the router.
  • 0

#11
JonF

JonF

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
I changed the router IP address and the other settings; The problem remained

The router is about 2.5 years old. I have not updated the firmware. I was talking to a friend that had a similar problem and he was told that this can happen when a router starts to go bad. If I power-down the router and then re-start, the problem goes away for a short time. But it comes back. This also makes me think that the router is on its way out.
  • 0

#12
amw_drizz

amw_drizz

    Member

  • Member
  • PipPipPip
  • 329 posts
Mine started doing the same. Since my network is a bit odd, I setup my Win2k3 server to handle DHCP and DNS and just have the router act as a router and nothing else.
  • 0

#13
hendaz

hendaz

    Member

  • Member
  • PipPipPip
  • 248 posts
In that case I suggest you buy a new router (a wireless N router will give you more speed and range than your current wireless G router). Until that point you will have to use static IP address on all devices.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP