Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem with external disc and administrator rights


  • Please log in to reply

#1
Moshi

Moshi

    Member

  • Member
  • PipPip
  • 34 posts
So few weeks ago I've been messing with something, I don't remember exactly what but afterwards I couldn't access my external My Book anymore as windows required some administrative rights (my windows account is an administrative one). With help of internet I somehow reversed the status so I could access my disc normaly but these icons were still there:

Posted Image

Note: Subfolders don't have that icon.

Problem came back today when I was sorting some files, trying to rename, copy, ... And windows wouldn't let me saying I need administrative rights! I couldn't even open the file normally in Subtitle workshop, saying it cannot be accessed. With help of Unlocker I moved the file to desktop and it worked normally there. So that mess I did weeks ago is to blame lots of files on My Book don't work as they should. So how can I fully repair this condition, clearly having something to do with accounts and administrative rights and stuff like that.

Thanks!
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,046 posts
  • MVP
these instructions are going to be a little fuzzy as i don't have win7 in front of me but.

right click on one of the locked folders and choose properties, then go to the security tab. then you should see a list of users that have access to that folder. there should be an add or edit button. click that and add the users group and give that group full permissions to the folder and press apply. the lock should disappear
  • 0

#3
Moshi

Moshi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 34 posts
I do not clearly understand what I should do as I already have some user groups added in there and all of them have full control.

Posted Image

Here is when I right click directly on disc:

Posted Image

By my amateur logic these settings should allow normal work and make those icons dissapear. But it's not like that... :D
  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,046 posts
  • MVP
on the H:\stuff folder, actually add the group called "Users" and give it full permissions and see if the icon disappears
  • 0

#5
Moshi

Moshi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 34 posts
Haha it works! Thank you very much!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP