Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Hardware configuration errors and Registry issues

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 7 posts
I am running an hp Mini 1137nr with Windows XP Home and SP3.
I have been having trouble with viruses for some time now and they have been attacking windows specifically, but am out of the country and away from any reinstallation disks and external drives, etc that would enable me to reinstall windows and hopefully fix my problems.
So, with my ever-"increasing" knowledge of windows, I've been doing what I can.

The major issue, this week, was that explorer.exe disappeared from c:\windows, something I tried to fix and thought I couldn't without installation disks, but I worked around that by using alt+ctrl+del and running new tasks as needed. Yesterday, my computer kept restarting when I turned it on. The BSOD read "stop:c000021a {Fatal Error} The windows logon process system process terminated unexpectedly with a status of 0xc0000034(0x00000000)(0x00000000)" which I later found to mean that winlogon.exe had now disappeared.
(Let me now say that at this point I just wanted to get the thing to load, so I may have done something stupid, though now it does load...)

Safe mode wouldn't work, I couldn't get it to do anything. My only options were repetitive restarts or Windows Recovery Console.
From the Microsoft Help site, I tried to fix the registries by doing this in Windows Recovery Console:

md tmp
copy c:\windows\system32\config\system c:\windows\tmp\system.bak
copy c:\windows\system32\config\software c:\windows\tmp\software.bak
copy c:\windows\system32\config\sam c:\windows\tmp\sam.bak
copy c:\windows\system32\config\security c:\windows\tmp\security.bak
copy c:\windows\system32\config\default c:\windows\tmp\default.bak

delete c:\windows\system32\config\system
delete c:\windows\system32\config\software
delete c:\windows\system32\config\sam
delete c:\windows\system32\config\security
delete c:\windows\system32\config\default

copy c:\windows\repair\system c:\windows\system32\config\system
copy c:\windows\repair\software c:\windows\system32\config\software
copy c:\windows\repair\sam c:\windows\system32\config\sam
copy c:\windows\repair\security c:\windows\system32\config\security
copy c:\windows\repair\default c:\windows\system32\config\default

Eventually I found a forum that said I could copy winlogon.exe from c:\windows\system32\dllcache IF it was there (which it was not) or from c:\i386 (which it was). Access was denied when I tried to copy from i386. So I "expanded" winlogon.exe to c:\windows\system32, and then expanded explorer.exe from c:\i386 to c:\windows.

Now, I can log onto windows, and explorer runs just fine.

The problem is that my User accounts are gone ("Admin" and "VickI") and the only User is "Owner". Fortunately, in c:\Documents and Settings there was a "Vicki" folder that contained all My Documents, Start Menu, Desktop files. Unfortunately, a lot of my hardware is not working.

When I open Device Manager, it lists Computer, IDE ATA/ATAPI controllers, Keyboards, Mice and other pointing devices, Other devices, Sound, video and game controllers, and system devices. Most pieces are listed under "Other Devices" and have a yellow exclamation beside them, These all say the drivers are not configured properly (Code 1). There used to be many more categories (ie, network adapters?!)

I looked in c:\windows\system32\drivers and the drivers all seem to be there, so I assume this is a registry issue?

Again, with some research, I looked through registry files for something fishy. I think where I should be looking is: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
Here, I found a ton of listings for the devices that are not working (ie network adapters: {4D36E972-E325-11CE-BFC1-08002bE10318}). There are also network adapter listings under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}.

This is as far as Ive gotten. If I have the drivers, and I have the registry keys, why are they not working?

I know I've royally screwed this up, but honestly I figured if I cant even start the computer, how much worse could it get?

If there is ANYTHING anyone can do to help, please please let me know.
Thank you.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP