Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unable to find WiFI Networks on Acer 3810T w/ Windows 7


  • Please log in to reply

#1
Mark W

Mark W

    Member

  • Member
  • PipPip
  • 35 posts
I have an Acer 3810T laptop and am running Windows 7 on it.
The problem I've had is my WiFi has been unstable. For example for 5 minutes or sometimes up to an hour I can easily find wifi networks in range of my laptop but then out of nowhere it disappears and I don't find any networks but any other WiFi device will find my router so I know it's laptop related.
I did some research on Google and found out this is an issue others have had with Windows 7 and it seems to be something to do with when updates are installed. I followed the advice to remove my WiFi drivers and reinstall them so I downloaded a file for the Intel drivers from Acer's website.
I went into Control Panel and removed 2 devices that were related to WiFi. I then did a scan for hardware and found one wifi device, an Intel WiFI Link 5100AGN. I installed the driver for this one. The problem is I know I removed two and this is the only one the scan found and I can't remember the name of the other wifi device/driver I removed.
Unfortunately ever since I did this my WiFi isn't working. In the control panel it shows all drivers are installed and working but when I click on the bars at the bottom of my screen no wifi networks show. I have tried going into the Network and Sharing Center and for example I select set up a connection or network and when I select Manually Connect to a wireless network it states "An Unexpected Error Occured" so I know something is missing that's allowing the WiFI to work. I hope when I get it corrected it may solve the original issue I had but does anyone know how I can get this working once again?

Thank you for your help.
  • 0

Advertisements


#2
SpywareDr

SpywareDr

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,771 posts
You might try using Windows' "System Restore" to roll Windows back to a previous state when your computer was functioning correctly:









Edited by SpywareDr, 10 May 2011 - 03:55 AM.

  • 0

#3
Mark W

Mark W

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
I didn't think of using System Restore but I'll give that a try.
  • 0

#4
SpywareDr

SpywareDr

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,771 posts
Got my fingers crossed . . . :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP