Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

age of empires 2

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
i have 2 computers wired into my netgear router. my kids like to play aoe2 against each other. lately we have been having problems connecting to the multiplayer via the LAN network. both computers can create the game. both computers can find each other in the show games window and we can click join. but neither one ever joins. it will make it to the "joining multiplayer game press esc if not joined in 15 seconds" screen but that is as far as it goes. after awhile it will go back to the show games screen and state "unable to join". what can i do to solve this problem? here are some other facts. not too long ago both computers were running real slow. 1 is about 4 years old and the other about 6 years old. i removed all malware and viruses. i also cleaned the registry using registry first aid. i did create a restore point incase there are any issues but i would like this to be my last resort since the computers are now running exceptionally faster. i use a westwell router for internet and the netgear router for file sharing. i had to reset my netgear because i could not remember my password.

thanks for any help you can give me.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP