Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't update ATI driver!


  • Please log in to reply

#1
Goggleplex-Googleplex

Goggleplex-Googleplex

    Member

  • Member
  • PipPipPip
  • 172 posts
I'm running XP Home on a Dell 5100C small form factor desktop. I have two

128 MB ATI RADEON X600 SE

graphics cards. I tried to update the driver but it doesn't update. The computer goes badda-bing badda-bong but when I look in Device Manager, the old driver is still there! :)

I tried many times. First I tried to install OVER the old driver.
Then I tried uninstalling the old driver before installing the new one.
I did scans for registry problems, (with EUSING FREE REGISTRY CLEANER).
I also scanned with AVAST and SPYBOT.

I guess I was tired and depressed yesterday and I shouldn't've attempted something like this at that time! I downloaded and installed two programs, (reg cleaners), (WiseFixer and one other that seemed to be the same program with a different name), that I uninstalled a few minutes later because I didn't really trust them after they tried to charge me money after coming up with a bizillion problems that "needed to be fixed by their program". (I wouldn't've had a problem with them if they charged up front but when something acts a little sneaky like that, I guess I get nervous.

I stoopidly did that BEFORE I used EUSING FREE REG CLEANER.

I ended up having to restore the system because after trying to update that driver, the computer was now hardly working at all! Every command I gave it, took forever to complete! Just getting Properties from My Computer took, maybe, almost 2 minutes!!!

Now everything seems to be working again but I still have the old driver.

The main reason why I want this slightly newer driver for my Radeom video cards is I'm running X-Plane flight simulator... and it's not running quite right. I was told by the company that there was a graphics driver problem.

Anyway, so now I'm gonna be super cautious, (unlike yesterday). That's why I'm asking for help here. :yes:

Any help will be very much appreciated. :)





More information:

When I clicked on "REMOVE" for the ATI Utility, (I think it said "Uninstall Utility), a message came up saying: Inisialization Error. I couldn't stop the process. It looked like the process was going to hang but it didn't. I went through the whole process of restarting and then trying to install the new driver. When the computer restarted, a new message came up saying:

cli.exe - Common Language Runtime ...

Application has generated an exception that could not be handled.

Rrocess id=0xa0 (160), Thread id=0x90 (144).

Click to terminate the application.
Click CANCEL to debug the application.

[OK] [Cancel]

And I looked in MyComputer and the old driver is still there. :unsure:

I'm now gonna restore to a restore point I created earlier today.
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP