Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Web Address Duplication


  • Please log in to reply

#1
KeithBravo

KeithBravo

    New Member

  • Member
  • Pip
  • 6 posts
I have a website ChessSetHeaven.com set up using iWeb and it is running fine.

The only problem is the address of each page duplicates the URL - for example, the Welcome page has an address of 'http://www.chessseth...om/Welcome.html '

I suspect this might affect its ranking with the search engines and, in any case, it doesn't look good.

Can I remove the second URL and if so how?

  • 0

Advertisements


#2
AstraNut

AstraNut

    Member

  • Member
  • PipPipPip
  • 384 posts
Log into your cPanel and go to File Manager. Expand your directory structure for your site. The complete site should be under public_html unless you made a separate folder with your domain name. Also, the home page needs to be named index.html and in the root directory. Use FTP if you can to do this as it is faster. Seems when I enter http://www.chessseth...om/Welcome.html I get an Internal Server Error. If I use http://www.chessseth....com/index.html, it defaults to http://www.chessseth...m/Welcome.html. The same if I use http://www.chessseth...m/Welcome.html.

Edited by AstraNut, 09 December 2011 - 08:05 AM.

  • 0

#3
KeithBravo

KeithBravo

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
I'm afraid I didn't really understand your answer as I am not an expert myself. However I did manage to solve the problem in line with your suggestions using the helpdesk at Hostgator.

Now however I have updated the site using iWeb and the URL duplication has happened again. :confused:

Does this happen every time I update the site? Is there a way I prevent this happening?

I can hardly call the helpdesk every day to temporarily solve the problem!
  • 0

#4
AstraNut

AstraNut

    Member

  • Member
  • PipPipPip
  • 384 posts
What was Hostgator's solution?

I don't use iWeb and it may be the problem when publishing your files. I think you have your site files under iWeb with a root directory named "www.chesssetheaven.com" and when the files are published to the root directory online, the "www.chesssetheaven.com" folder name is included. That means when you enter http://www.chesssetheaven.com you get "http://www.chessseth...m/Welcome.html" If welcome.html is your home page, it should be index.html and all files under the second folder called "www.chesssetheaven.com" should be under the root directory named "public_html". I'm just guess here without a screenshot of your cPanel's expanel root directory. Might check how iWeb is set up to publish files and if it includes the named root directory you made. Not sure if your .htaccess file had changes made.
  • 0

#5
KeithBravo

KeithBravo

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Thank you for that. Yes, I understand your thinking and it makes sense.

To be honest I'm not entirely sure what the guy at Hostgator did as he nipped off to do something on his own at one point. Following what happened I think (and I apologise for the non-technical explanation) is he removed one file and moved it up a level. This removed the need for the second URL.

I am assuming this is what you meant too.

Clearly there must be somewhere in the iWeb settings that is causing the problem. I have taken a screenshot of what is probably a relevant screen and have attached it.

Attached Thumbnails

  • iWeb CSH Screen shot 2011-12-20 at 22.01.53.png

Edited by KeithBravo, 20 December 2011 - 04:04 PM.

  • 0

#6
AstraNut

AstraNut

    Member

  • Member
  • PipPipPip
  • 384 posts
I believe your Directory/Path should just be public_html/ . That's why, when published, the FTP makes a new folder called ChessSetHeaven.com. Try changing this and see if you have same problem next time you publish.
  • 0

#7
KeithBravo

KeithBravo

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Thank you, AstraNut.

I have changed the information for future posts but how do I put the existing site right?

Looking on Filezilla I can see where I have the extra Directory but am a little loathed to remove it in case I wreck the site.

How do I safely remove the additional Directory/Path?
  • 0

#8
AstraNut

AstraNut

    Member

  • Member
  • PipPipPip
  • 384 posts
When using FileZilla, select rhe second directory. Everything under it will be your site. Highlight everything and either drag/drop it into the public_html directory or cut/paste into the public_html directory. Whichever you feel comfortable with. You should maintain a backup on your own computer of all files exactly as they exist online.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP