Jump to content

Free help from tech experts
Welcome to Geeks to Go forums. Create an account now to gain access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing topics, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. Best of all, registration and all assistance is 100% free! This message, and all ads will be removed once you have signed in.
Sign In Create Account

Images on Facebook not loading in any browser


  • Please log in to reply

#1
stepherta

stepherta

    New Member

  • Member
  • Pip
  • 1 posts
Hi, any advice would be appreciated because I am at my wit's end! For the last week images on Facebook are not loading properly. Some images load, others do not, both my own photos and my friend's. This is a problem on the newsfeed and I click on individual images. They either show up as a white or grey box, or perpetually load and never appear. This issue is only on my laptop, on my desktop I can see everything properly. It is also occurring in IE, Firefox and Chrome. I have cleared all temp files, browsing history, cache, cookies ect with no luck. I also checked that there were no blocks on loading images in my browser settings. Lastly I looked at my anti-virus settings and don't see anything that should be affecting this (though I'm not exactly sure what I am looking for). The anti-virus programs I am running are Sophos, AVG and Microsoft Security Essentials.

Please help me if you can! This is driving me nuts. Thanks so much in advance.

Attached Thumbnails

  • facebook.screenshot.JPG
  • facebook.screenshot2.JPG
  • facebook.screenshot3.JPG

  • 0

Similar Topics: Images on Facebook not loading in any browser     x


#2
ScHwErV

ScHwErV

    Member 5k

  • Retired Staff
  • 21,285 posts
  • MVP
First things first.

Don't use multiple different antivirus programs. They'll fight each other for control and end up causing you problems. Stick with MSE, dump the rest.

When you cleared the temp files, how did you do it? Which program did you use?

Are you using the most updated versions of IE, Chrome, and FF? How about Java and Flash?

Remember GIGO. I've got to ask questions.

Give this a shot.

Make sure you've updated everything first (browsers, java, flash). Download TFC. Close all your browsers and run it. It will reboot. Then try Facebook and see what happens.
  • 1

#3
iNeedMuchHelp

iNeedMuchHelp

    New Member

  • Member
  • Pip
  • 1 posts
I've been having this problem too- but it is on my most updated system. My super-old laptop- where I have not lately updated anything- is fine with the images. I don't have wacky security software. It's gotta be some mix between the system and lack of update like you are saying- like Java or Flash. My boss, who has my same era iMac is having the same issue. If anyone gets a clear idea, please post it! Thanks!
  • 0

#4
varun777sharma

varun777sharma

    New Member

  • Member
  • Pip
  • 2 posts
hello sir i have a lot of problem with my chrome creating trouble form last week.
my Facebook id did not log in. my gmail ends with to many restrictions many other sits also not open properly.
other software like firefox and opera opens facebook but doesn't show any picture.
i do all things like clearing cookies. etc etc but nothing works
help me with this i am using win xp....
  • 0

#5
varun777sharma

varun777sharma

    New Member

  • Member
  • Pip
  • 2 posts
and my antivirus doesn't update.
  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

As Featured On:

featured