Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Rediculous serial ports


  • Please log in to reply

#1
Qinx

Qinx

    Member

  • Member
  • PipPip
  • 11 posts
Where does Windows XP get this high COM port numbering from?

When installing Bluetooth COM ports, it starts counting at COM44 (and I cannot change this either). When checking with a regular COM port, in the pull down list where you could change it, it says that COM3-COM44 and COM52-COM57 are all in use.

How can i check what is using those COM ports? Can I free any of them up so that my BT COM ports start with COM3?

This is an issue, since MS ActiveSync does not allow me to use the COM ports that are currently assigned to the BT adapter. It let's me select COM1 only. So I cannot use Bluetooth to sync my iPAQ with my PC.
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
i thought the device driver....what bluetooth adapter?
  • 0

#3
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
I have a Trust Class I USB Bluetooth adapter. The adapter works fine (after fiddling around with drivers). It's recognized at first as a Silicon Wave Bluetooth Wireless Adapter. But the default driver doesn't work, so I need to install a driver created by WIDCOMM.

However, there is no problem at all in Win2000, so i really think there is an issue with all the ghost COM ports that have been assigned to something by someone.
  • 0

#4
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
hmm, any place I can download the driver?

Where do you see these com ports? Device manager?
  • 0

#5
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Well, I got the driver with the installer program at http://drivers.trust...13853-02_01.exe

(It should be in English as well, not just Dutch). Beware, it's a self-extracting file that runs setup.exe right away. Since you don't have this particular BT adapter, you don't want that.

I noticed the ports being "in use" when looking at the properties for the regular com port that I have, COM1. After pressing "Advanced" in the "port settings" tab, you get a window where you can give the port a number by selecting it from a pull-down list. With all ports from COM3 to COM44, it says "in use".
  • 0

#6
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
More info:

Could it be "junk" in my registry? I went in and just search for COM3, then noticed that COM3x are all connected to something with bluetooth, while it doesn't say so in my device manager.

If so, how can i clean them up in my registry?
  • 0

#7
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Hmmm, this story sounds familiar, only it applies to Windows 2000, where I'm using XP. And ofcourse, in XP there is no way to manually remove devices, so I cannot use the same procedure. Still:

http://support.micro...om/?kbid=271523
  • 0

#8
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
http://help.lockergn...ndpost&p=224436

Give the man a cigar!!! With the little trick where you can show hidden devices, ALL the so called "Ghost serial ports" showed up. And I could remove them all.

If you're not going to read the article under that link: apparently bluetooth under XP is a real nightmare. Old serial ports are kept in use. The topic shows a way to make them show up in the Device Manager. Removing them becomes easy-peasy!!
  • 0

#9
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
pretty sure you can just do that by clicking VIEW > SHOW HIDDEN DEVICES within DEVICEMANAGER...


Bigger question. did that solve the problem?
  • 0

#10
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Well... when I chose "hidden devices" before, I didn't see any of those "ghost serial ports". After setting that environment variable thingy in that topic, I did.

Actually, I thought that was the fix, but you make it sound that it should have shown the hidden devices regardless?

Anyway, I'm currently removing all those ports that I have there (it takes quite long for each single one, is that normal?). After, I'll probably have to re-install the bluetooth things completely, and then I'll get back to tell if I can use ActiveSync. But I have good faith :tazz:
  • 0

#11
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
It works brilliantly!!

So the problem was indeed all those hidden ports. Apparently, when ActiveSync starts looking for serial ports, it stops when it hits a hidden port or something. Now that I removed all those, I can select all 16 (!) com ports.
  • 0

#12
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
well, that is interesting...good job!
  • 0

#13
Qinx

Qinx

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Yeah, great! Thanks for your time!!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP