Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

ATI Catalyst Control Center won't open anymore

  • Please log in to reply




  • Member
  • PipPipPip
  • 344 posts
As the title says my ATI Catalyst Control Center won't open anymore, I don't know why but I do have the latest drivers from the AMD/ATI website. I've tried opening from the tray and right clicking the desktop, I've tried uninstalling/reinstalling and clean installing. I've rebooted several times and no fix thus far.

Edited by hayabusa_mike, 08 May 2012 - 05:45 PM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP