Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

File Sharing Access Denied


  • Please log in to reply

#1
timetowaste

timetowaste

    Member

  • Member
  • PipPip
  • 54 posts
I've setup a home network between two computers connected through a router (DI-604). The main computer is Windows XP Home SP2 and the other is Windows 98se. I"ve set a few files to be shared on the network. Of the three users files I"ve set to share, only one of them you can actually acess the files. With the of ther two users files when you go to open it a message pops up saying access is denied.

What am I doing wrong?

Thanks for your help.
  • 0

Advertisements


#2
djgotee

djgotee

    Member

  • Member
  • PipPipPip
  • 269 posts
There can be other items inviolved, however, take a look at the following first :

Start by hooking all comps up with cat5 cables as a wired type system, then,

(this applys to 2 machines--one 9x, one Xp home)
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
Make a shared folder on the 9x machine.
Go to my computer and right click shared documenst on the xp home machine and go through the proceedure to make it shared. Select "share this folder on the network and allow network users to change my files".

For the duration of testing, enable the Guest account on XP(see below). If all works, you can deal with that issue later (username/passwords for everyone on every PC)

Client for Microsoft Networks needs to be the primary network logon for all other machines

All machines are in the same workgroup

All machines have to have the same protocals

Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP. Click Start, click Control Panel, and then click Network and Internet Connections. Click Network Connections.
Right-click Local Area Connection, and then click Properties. Click Internet Protocol (TCP/IP), and then click Properties. Click the General tab, and then click Advanced. Click the WINS tab. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times. Click Close to close the Local Area Connection Properties dialog box. Close the Network Connections window.

Step 2: Start the Computer Browser Service Click Start, right-click My Computer, and then click Manage. In the console tree, expand Services and Applications.
Click Services. In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start. Close the Computer Management window.


The above is only a start, other items have to be considered also, however, its a good idea to try to do these basic things first...

Oh and also...:

Make sure you are logged on with user name and password for all computers, otherwise there will be authentication problems.
XP home uses auto logon as the default. The first logon is done as owner without a password. When you then setup a user account and logon, you do not get the user prompt because of auto logon. And, you are not logged on as new user, but still as owner, so you are not authenticated as expected by other computers. To resolve this, , use control panel, users and disable auto logon. Then log off and on again as the desired user.

Oh and by the way....if you have a comp. with xp home on it, it is simple file sharing by default, and simple file sharing only. Sometimes on an xp home comp, the activation for the guest account gets set off. In this case, youd have to activate the guest account with :

net user guest /active:yes (in CMD)

Edited by djgotee, 05 June 2005 - 07:59 PM.

  • 0

#3
timetowaste

timetowaste

    Member

  • Topic Starter
  • Member
  • PipPip
  • 54 posts
Thanks for your help but no success.

What doesn't make sense to me is that all files are from the same computer were setup to share the same way and two of them don't work.

What are other possible reasons for access denied messages with file sharing?

I think it has something to do with the user setup in windows XP because only the two users documents are denied. I could set any other file to be shared and it would work fine.
  • 0

#4
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Did you set these

http://support.micro...kb;en-us;281248

http://support.micro...kb;en-us;328170

http://support.micro...kb;en-us;304040

Edited by Keith, 06 June 2005 - 10:07 PM.

  • 0

#5
timetowaste

timetowaste

    Member

  • Topic Starter
  • Member
  • PipPip
  • 54 posts
I tried searching the the Microsoft site and didn't find that helped.

I have go it working. I don't know what is different but it works. All I did what set the files to not share and them reset them to share. It just worked after that.

Thanks for all your help.

Edited by timetowaste, 06 June 2005 - 10:30 PM.

  • 0

#6
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Thank you for posting the solution
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP