Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

problem: Multiple ipv4 addresses on single eth-card.


  • Please log in to reply

#1
JohnDoge

JohnDoge

    New Member

  • Member
  • Pip
  • 3 posts
Howdy.

A brand new Fujitsu W530 Power with an Intel card is giving me and the other IT-guys at work a real head scratcher. This is something that none of us has seen before, and some of us have been working with computers for a very long time.
The problem?
The Intel ethernet card is recieving 2 separate and different IPv4 addresses. This is a problem for our customer, as his surveillance programs have a problem with it, and drops his connection.
What we've tried:
Reinstalling w7. Twice.
Tried upgrading / downgrading drivers.
Different networks and the problem keeps repeating itself.
Tried following this guide, to no avail. http://williamfaulkn...esses-in-vista/


A couple of hours of googling and reading up on this and not a single answer to be found anywhere, and so I'm now turning to you guys.

Please note I am running a swedish OS, but if there's any questions, i'd gladly answer them. Also excuse any misspellings or grammar, as english is a second language for me.

The error message I'm getting after trying to release the second IP is An address has not yet been associated with the network endpoint.


Any other info you need, I'll be happy to give.
I have attatched a couple of screenshots that shows you my problem. Again, swedish OS, but if you're used to windows, you will be able to see what I mean.

Has anyone ever seen this before?

Many thanks in advance.

JohnDoge

Attached Thumbnails

  • 2x ipv4.jpg
  • 2x ipv4 (2).jpg

Edited by JohnDoge, 28 January 2014 - 03:43 AM.

  • 0

Advertisements


#2
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts
Hi,

From the screen it seems you have an Alternated IP address configured and for some strange reason the computer get's the IP from the DHCP server but didn't disable the Alternated IP!

On the following link there is a somehow related problem maybe you can dig more with the commands suggested on that blog.
http://lyngtinh.blog...ation-ipv4.html
  • 0

#3
JohnDoge

JohnDoge

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

Hi,

From the screen it seems you have an Alternated IP address configured and for some strange reason the computer get's the IP from the DHCP server but didn't disable the Alternated IP!

On the following link there is a somehow related problem maybe you can dig more with the commands suggested on that blog.
http://lyngtinh.blog...ation-ipv4.html



Hi!

Thanks for the help, but that did not work!
It all entered fine and the command seemed to work in cmd(i tweaked it because its the DHCP i _do_ want), but in practice, the loopback pseudo interface wasn't shut shutdown anyway.
I've contacted the manufacturer, and they'll be arriving with a new motherboard in a couple of days, but it is, in my opinion, a very interesting problem. If it can be fixed in another way, i'd like to know, in case i get more computers delivered with this problem.

Any suggestions?

// Doge
  • 0

#4
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts
Hi,

Do you have the Alternated IP address set? and it's needed?
  • 0

#5
JohnDoge

JohnDoge

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

Hi,

Do you have the Alternated IP address set? and it's needed?


Hi,

No, sir, it is neither set nor needed.
  • 0

#6
SleepyDude

SleepyDude

    Trusted Helper

  • Malware Removal
  • 4,149 posts
In that case I would try the following...

The steps that I am about to suggest involve modifying the registry. Modifying the registry can be dangerous so make a backup of the registry first by creating a System Restore point before proceeding. Modification of the registry can be EXTREMELY dangerous if you do not know exactly what you are doing so follow the steps that are listed below EXACTLY.

Disable APIPA on All but One Network Adapter

  • Use Registry Editor to create the following registry key, where <var>adapter name</var> is the name of the Dynamic Host Configuration Protocol (DHCP) configured adapter where you want to disable APIPA:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\Interfaces\<var>adapter name</var>
  • Add the following value to this key:
    Value name: IPAutoconfigurationEnabled
    Value type: REG_DWORD
    Value in hexadecimal: 0 (A value of 0 disables APIPA support on this adapter)
    NOTE: If the IPAutoconfigurationEnabled entry is not present, a default value of 1 is assumed, which indicates that APIPA is enabled.
  • After you make this change, restart your computer.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP