Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Acer 5737z shuts off by itself! (Fan doesn't work)


  • Please log in to reply

#1
andrefrsilva

andrefrsilva

    New Member

  • Member
  • Pip
  • 1 posts
When I start it, the fan works for a second and then shuts down. Then after a couple of minutes or seconds (it's shortening) the computer shuts off (at that moment the fan works again for a millisecond).
There's a print screen a second before it shuts off:

Posted Image

I already cleaned all components and also the thermal paste. Didn't work.

I tested the fan on another computer and it worked perfectly.

I should also say that I'm using a different charger (using: 20V 3.25A / original: 19V 3.42A). But the same happens when I'm using its battery, so I don't think this is the issue.

I appreciate your help.

Edited by andrefrsilva, 15 February 2014 - 06:09 AM.

  • 0

Advertisements


#2
itcareonline

itcareonline

    New Member

  • Member
  • Pip
  • 6 posts

When I start it, the fan works for a second and then shuts down. Then after a couple of minutes or seconds (it's shortening) the computer shuts off (at that moment the fan works again for a millisecond).
There's a print screen a second before it shuts off:

Posted Image

I already cleaned all components and also the thermal paste. Didn't work.

I tested the fan on another computer and it worked perfectly.

I should also say that I'm using a different charger (using: 20V 3.25A / original: 19V 3.42A). But the same happens when I'm using its battery, so I don't think this is the issue.

I appreciate your help.

As per the snap attached it shows that the GPU temp is very high which means that graphics releated chip is making some problem.
Due to this high temp. of GPU ur device is shutting off after few minutes.
I consider it is a motherboard problem releated to grpahics chip.
so it goes to chip level repairing.
if it's not in warranty better u get repaired from ur nearest shop.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP