Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Remote Desktop Connection


  • Please log in to reply

#1
tk3608

tk3608

    New Member

  • Member
  • Pip
  • 9 posts

I have a client who has a Windows remote desktop connection that was setup on his computer without permission from him.  Does anyone know how to remove a Windows Remote Desktop Connection from a client-side computer that is running Windows 7 Home Premium?


  • 0

Advertisements


#2
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,090 posts
  1. Right Click Computer –> Properties
  2. On the left hand menu pane, select “Remote Settings”
  3. Under Remote Desktop, select Don't allow remote connections to this computer.
  4. Click Apply and OK as needed.

Another way is to disable the 3 Remote Desktop services.

 

Press Windows key + R, type services.msc and press Enter.

Scroll down to the 3 Remote Desktop entries.

Double click on each in turn.

Set Startup type to Disabled.

Click on the Stop button.


  • 0

#3
tk3608

tk3608

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts

Thank you. I will try this.


  • 0

#4
tk3608

tk3608

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts

This fix did not get rid of the remote desktop connection entry in the Network area of "My Computer".  Do you have any other methods that I could try to remove this entry with?


  • 0

#5
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

This fix did not get rid of the remote desktop connection entry in the Network area of "My Computer".  Do you have any other methods that I could try to remove this entry with?

 

Can't you just right-click on that connection and select "Delete" ?


  • 0

#6
tk3608

tk3608

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts

No.  The pop up box asks for a username and password for the remote desktop connection


  • 0

#7
tk3608

tk3608

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts

I have tried a Microsoft fix.  I have navigated the registry and searched for a registry key that was non-existent under Hkey current user called Default, an attribute of Terminal Server Client.  I followed the path given exactly as shown. No change.


  • 0

#8
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

No.  The pop up box asks for a username and password for the remote desktop connection

 

It asks for credentials in order to DELETE that Remote Connection ? That's weird.


  • 0

#9
tk3608

tk3608

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts

I tried right-clicking the entry and there are three options given:  1. Expand   2.  Connect with remote desktop connection and   3. Open in a new window.  When I left click I can't connect which makes sense because I have disabled the services and changed the configuration for remote desktop.


  • 0

#10
Aura

Aura

    Special Ops

  • Malware Removal
  • 2,563 posts

I tried right-clicking the entry and there are three options given:  1. Expand   2.  Connect with remote desktop connection and   3. Open in a new window.  When I left click I can't connect which makes sense because I have disabled the services and changed the configuration for remote desktop.

 

I'm really more of a visual person. May I ask you to provide screenshots of the location of that RDP icon please ?

It would help me a lot in assisting you. Do you know how to take a screenshot and post it on a forum ?


  • 0

#11
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,090 posts

Open a Elevated Command Prompt. Enter

 

reg query "HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default"
 

If the response is:

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns

 

then there are no defined Remote Desktop connections.

 

If it's something like:

 

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default
MRU0    REG_SZ    192.168.1.2:3390

 

then there is one. Each connection is assigned a MRUn entry under the registry key.

 

Try  doing the reverse of this:

 

 

Installing the Remote Desktop Web Connection Toconnect to your machine from a remote location, you must install the

Remote Desktop Web Connection on the Windows XP system you want to

access remotely. This feature is basically a component of XPs Internet

Information Services (IIS).To install the necessary files for the Remote Desktop Web Connection, you will need to have access to your Windows XP CD.To Install IIS and the Remote Desktop Web Connection, follow these steps:
  1. From the Control Panel, click the Add/Remove Programs applet.
  2. Click Add/Remove Windows Components.
  3. Select Internet Information Services and click Details.
  4. Select World Wide Web Services from the Subcomponents of Internet Information Services and click Details.
  5. Select the Remote Desktop Web Connection check box and click OK.
  6. Click OK, then click Next to install and configure IIS and the Remote Desktop Web Connection.
  7. Click Finish when complete.

 

 

This should remove RDT completely.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP