Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

All of a sudden no beep during boot


  • Please log in to reply

#1
TK1556

TK1556

    New Member

  • Member
  • Pip
  • 1 posts

Hi all,

 

I built my wife's computer in late 2012 and worked fine for a while. Now, however, when we try to boot it up all fans and lights turn on, but we're not getting anything up on the monitor and there is no beep at all.  Any help is much appreciated.

 

Build:

Motherboard-  Gigabyte GA-970A-UD3

Graphics-  MSI R7850 Twin Frozr OC AMD Radeon HD 7850 2GB GDDR

CPU-  AMD FD8350FRHKBOX FX-8350 FX-Series 8-Core Black Edition

Memory-  2x G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)

PSU-  Rosewill Green Series RG630-S12 630W

Windows 9 Professional if that makes a difference...

 

 

Thanks again.


  • 0

Advertisements


#2
phillpower2

phillpower2

    Tech Staff

  • Technician
  • 20,019 posts

:welcome:   TK1556

 

You are not getting a beep because the MB is not passing the power on self test (POST) and as you are getting nothing on the screen it is possibly the GPU that has issues, try removing both sticks of Ram and then turning on the power, if you get error beeps it suggests that the Ram may be ok but the GPU or CPU are bad.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP