Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

YouTube will load but not play video


  • Please log in to reply

#1
Disaresta

Disaresta

    Member

  • Member
  • PipPip
  • 46 posts

Hey guys,

 

So I'm having a rather odd problem here. Since earlier today, YouTube videos will load fully, but will not begin to play. See the screenshot below.

 

ax051e.png

 

The first frame of the video is shown, and, if given enough time, the video will buffer to completion. In addition, the "Pause" icon (which is displayed when a video is playing) is in the bottom left corner. However, clicking on it doesn't do anything except change "Pause" to "Play -- the video will not actually change at all. Neither does skipping to various points in the video -- this will display one frame of the video at that point, but will not play it. I have tried to watch many different videos with the same result.

 

Any advice? :unsure:


Edited by Disaresta, 15 July 2014 - 08:23 PM.

  • 0

Advertisements


#2
Lars330

Lars330

    New Member

  • Member
  • Pip
  • 1 posts

I'm having this exact problem. It started occuring after a windows 8 update a few days ago. Sometimes a restart fixes it but not all the time. Also since the windows update whenever I start my laptop, it has no sound whatsoever! I have to reboot to get the sound to work again.

 

These problems might be related. Are you experiencing sound issues as well?


  • 0

#3
Disaresta

Disaresta

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts

My sound is working fine. :confused:

 

The problem seems to have gone away when I restarted my computer. However, I'll keep my eye out for if it happens again.


  • 0

#4
HelpMeHelpYou

HelpMeHelpYou

    Member

  • Member
  • PipPipPip
  • 172 posts

Right click on the page (Youtube) and go down & click (View page info) (Security) (View Coockies) (Remove all Cookies)


  • 0

#5
Aura

Aura

    Special Ops

  • Visiting Consultant
  • 2,480 posts
You can use TFC (Temp File Cleaner) to clean your browser's cache and also other cached files.
If it doesn't work, consider restting your browser's settings too.

For now the issue seems to have been solved, but try the suggestions above if it comeback.
  • 0

#6
HelpMeHelpYou

HelpMeHelpYou

    Member

  • Member
  • PipPipPip
  • 172 posts

Also any of the addon's you see that tell you "This fixes Youtube Videos or this helps speed up Youtube Downloads" Do not use these! There trash and make your whole computer run like crap! I have tried them all. with no added items i do not hit pause to let it download before playing. It is ready to play when the page loads.


  • 0

#7
SANDSTER

SANDSTER

    New Member

  • Member
  • Pip
  • 5 posts

Loving this site. I am experiencing this problem right now, I cannot wait to try one of these ideas...thanks to all who help here.


  • 0

#8
AlexSpoettel

AlexSpoettel

    Member

  • Member
  • PipPip
  • 14 posts

Loving this site. I am experiencing this problem right now, I cannot wait to try one of these ideas...thanks to all who help here.

 

Just logged in to give another idea that fixed it for me. For me videos would not play in any browser at all. Rebooting did not fix it everytime, although it sometimes did.

 

If you use an audio interface, unplug and then replug it. Fixed it instantly for me. Especially Focusrite devices seem to cause this problem alot.

Since this is audio related you might try to deactivate and reactivate your main sound device in the "Sound" section of Windows Control Panel.

Checking for audio driver problems could be a solution as well, they might be corrupted.

 

tl;dr This problem might be sound driver related. Replug all audio interfaces/devices and reactivate them in the Control panel.


  • 0

#9
Ostalstew

Ostalstew

    New Member

  • Member
  • Pip
  • 2 posts
Why YouTube Videos Not Playing 
1. Brower is outdated
2. Adobe Flash Player is not available
3. Too many cache and cookies
4. No JavaScript support

  • 0

#10
jakekovoor

jakekovoor

    New Member

  • Member
  • Pip
  • 2 posts

Before I lay down the 13 Ways to Fix if YouTube is loading but not playing videos, its best if you understand the root of the problem so that you can tackle the problem head on.

But if you are as impatient as me, then you can just skip straight to to the 13 Methods :)

 

 

Understanding Why Your Youtube is loading but not playing videos
 

If you haven't read Saint’s in-depth article/analysis on How YouTube Videos Work (Infographics) then what you should know is that YouTube uses HTML5 Video Player as the video playback capability to play all of your videos.

Whenever, we try to watch videos, your computer (or basically any device) and YouTube’s servers connect by distributing and consuming data in large packets. When these packets are sent to your computer to allow the video to run, the HTML5 player of your browser will play the video.

At that point a lot of things can come and interfere the connection between your computer, YouTube and the HTML5 player.
 

This includes

  • your Internet connection.
  • your external audio programs
  • different bitrates
  • your Adobe Flash Player
  • your Browser settings
  • your stored page Cookies and Cache
  • your browser plugins
     

Hence, in order to get your videos to play, you have to remove these obstacles in order for it to sustain a good connection and not make your videos buffer or freeze.

 

 

How to fix YouTube Videos loading but not playing: 13 Simple Methods
 

Follow Saint’s article, for the steps and for the full exclusive 21 Methods)

 

  1. Refresh your browser page
  2. Adjust the Video Quality
  3. Check your Internet Connection
  4. Deleting your Cache, Browsing Data and Cookies
  5. Resetting your Browser’s settings
  6. Disable All Plugins
  7. Update your Browser
  8. Restarting your computer
  9. Enable Javascript
  10. Disable Youtube HTML5 Player (Chrome Extension)
  11. Replugging Your Audio Devices
  12. Updating the Sound Driver
  13. Reinstalling the Sound Driver

 

 

 

Sources


Edited by jakekovoor, 10 January 2017 - 11:44 PM.

  • 0

#11
Ostalstew

Ostalstew

    New Member

  • Member
  • Pip
  • 2 posts

 

Why YouTube Videos Not Playing 
1. Brower is outdated
2. Adobe Flash Player is not available
3. Too many cache and cookies
4. No JavaScript support

 

1. Brower is outdated

  • Solution: Upgrade your browser to the latest version by following its update instruction.

2. Adobe Flash Player is not available

  • Solution: Adobe Flash Player is a necessary part used by your Chrome/Firefox/IE/Safari browser, which enables you to have a good YouTube watching experience. So make sure that you’ve installed the latest version of Adobe Flash Player in your browser.

3. Too many cache and cookies

  • Too many caches and cookies will lead to video not playing on YouTube. Therefore, you should clear caches and cookies and then restart the browser to play YouTube videos again.

  • Firefox: Click Firefox Menu > History > Clear Recent History > Details > Cache > Clear Now; Chrome: Click Chrome Menu > Settings > Show Advanced Settings > Clear Browsing Data > Empty the Cache/Delete Cookies;

  • IE: Click Gear icon > Safety > Delete Browsing History > Temporary Internet Files/ Preserve Favorites Website Data > Delete;

  • Safari (for Mac OS X): Click Safari Menu > Empty Cache > Empty.

4. No JavaScript support

  • It is an important part to let any feature work well. So you need to check the JavaScript and make sure it is running on website.

  • Chrome: Open a new Chrome browser window > Type "chrome: //settings/content" into the address bar and click "Enter" > Mark "Allow all sites to run JavaScript (recommended)" in the pop-up window > Click "Done" to save the setting.

  • Safari: In the "Edit" drop-down menu at the top of the window, select "Preferences..." > Select the "Security" icon on the top list of the window > Then, check the "Enable JavaScript" checkbox > Close the window to save your changes > Click "Refresh" to refresh Safari browser.

More Detail please visit: Easily Fix YouTube Videos Not Playing Issues


Edited by Ostalstew, 21 January 2017 - 07:41 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP