Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't open Excel or Word attachments from email.


  • Please log in to reply

#1
Triskelion

Triskelion

    Member

  • Member
  • PipPipPip
  • 652 posts

When I go into my email [either Outlook or Webmail], I can't open any word or excel attachments.

When I click on them I keep getting the same message;

 

 

The operating system is not presently configured to run this application.

 

Then when I click okay, I get the message;

 

 

The file is corrupt and cannot be opened.

 

I thought it was a one off and just that email, but it happens with EVERY excel file. Not every file I get can be corrupt.

 

Now if I save the same file to my desktop.. I can open it just fine.

 

Hopefully someone can help?


  • 0

Advertisements


#2
ruggie_uk

ruggie_uk

    Trusted Helper

  • Malware Removal
  • 2,083 posts

Hi.
What version of Windows and office are you using?

This can happen when the temporary version of a file is used, which happens when viewed from an email client or via a webpage due to restricted permissions. Which explains why copying it to your desktop works correctly as you are then accessing via standard permissions.

You can try the following:

Set component security settings back to the defaults:

1. Open Control Panel.

2. Open Administrative Tools.

3. Open Component Services and expand the tree under Console Root to Computers --> My Computer.

4. Right-click My Computer and select Properties.

5. Select the Default Properties tab and set the following values:

Default Authentication Level: Connect

Default Impersonation Level: Identify


  • 0

#3
Triskelion

Triskelion

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 652 posts

I'm using Windows 8.1.. and Office 2013

 

Going to try what you said..

 

My settings are already as you suggested. with Connect & Identify.


Edited by Triskelion, 14 October 2014 - 07:57 PM.

  • 0

#4
ruggie_uk

ruggie_uk

    Trusted Helper

  • Malware Removal
  • 2,083 posts
If everything is set properly then if you have the disks I would suggest a reinstall of office as that is the only solution I am aware of for this particular problem.
First I would uninstall it.
Then run the cleanup tool before reinstalling.
It is possible something got messed up along the way.
 
Cleanup Tool

Edited by ruggie_uk, 15 October 2014 - 06:06 AM.

  • 0

#5
Triskelion

Triskelion

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 652 posts

Will I lose all my emails and contacts from Outlook then?


  • 0

#6
ruggie_uk

ruggie_uk

    Trusted Helper

  • Malware Removal
  • 2,083 posts

If you are using outlook then it is a bit more involved but nothing too taxing.

 

Your PST files should remain but rather than take the chance, you can export them all to a file. You will however have to re input your account settings for your email.

 

Rather than me type it out for you, here is a link from microsoft that details the procedure: http://office.micros...A102809683.aspx


  • 0

#7
ProgramGeeks

ProgramGeeks

    Member

  • Member
  • PipPip
  • 42 posts

I have never actually liked Microsoft Office. I use a free office suite that is almost exactly like Microsoft Office. Its called Libre Office.

 

You can download it from here:

http://www.libreoffi...reoffice-fresh/

 

I have used this for a long time and never ran into any problems!


  • 0

#8
hazard209

hazard209

    Member

  • Member
  • PipPip
  • 71 posts

When you checked the Component Security Settings, was the "Enable Distributed COM on this computer" box checked?

 

If it is checked then maybe it's something with Office that's the problem.

 

Try this:

1. Open Excel.

2. Go to the File tab and select options.

3. Click on Trust Center and then the "Trust Center Settings..." button.

4. Select FIle Block Settings.

5. Click Restore Defaults.

6. Try opening an Excel Document from Outlook.

 

 

If that doesn't work, you can try this as well:

1. Open Excel.

2. Go to the File tab and select options.

3. Click on Trust Center and then the "Trust Center Settings..." button.

4. Select Protected View.

5. **Uncheck "Enable Protected View for Outlook attachments"**

 

Then try opening an Excel document that you can trust from Outlook and see what happens.

 

**Note that this feature protects your computer from potenially malicious files. Disable it at your own risk.**


Edited by hazard209, 08 November 2014 - 12:16 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP