Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Presario 1700 LCD signal loss


  • Please log in to reply

#1
KevinLee

KevinLee

    New Member

  • Member
  • Pip
  • 1 posts
Hello,

I have a Presario 1722.

The screen loses its data and goes to a bright screen. Everything still works. My desktop is still up and if I was playing music it still plays.

I boot the computer down and then back up with the power button and it boots OK. I can hear the Windows XP 'song'.

If I give the bottom of the case a slap it wil lsometimes bring back the display.

Any ideas what this might be.

I have checked some ribbon cable connections and they seem ok.

Thanks

Kevin
  • 0

Advertisements


#2
austin_o

austin_o

    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi Kevin. Welcome to Geeks to Go. I would suspect the monitor or the graphics card is the problem. If a "slap" on the case fixes it, it is hard to issolate such a fix. Do you have video on board the mother board or a separate graphics card? You could try re-seating the graphics card if it is separate. You could try another monitor, maybe a friends and see if the monitor is the problem.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP