Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Printer Sharing on Home Network


  • Please log in to reply

#1
fuoleum

fuoleum

    Member

  • Member
  • PipPip
  • 26 posts
I'm in dire need of some help from you people please...

I've set up a network using the wizrd thing. I'm running XP on the host and connected to this via a crossover cable is a Windows Me machine. Wizard made me a disk to run on Win ME PC, which I did.

Internet access is via cable broadband on the host. This is working great on both PCs. I just installed a printer, which I set to be shared on the network.

The hard-drives of each computer are visible (and browsable) on both machines via Windows Explorer.

If I go into networks, my mini network is their (on both PCs) together with my two computers and their names (again, on both PCs).

The problem is that when I try to install a network printer on the ME machine it tells me I can't access the host PC, as I have no permission to access the resource. I get the same message if I navigate to the workgroup and double-click the host PC in My Documents. If I do this on the host PC however, I can expand each PC in the network and explore further.

How do I set permissions?
<_<

Many thanks for your knowledge and expertise!
  • 0

Advertisements


#2
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Right click on the object you would like to change permissions for and click on sharing and security then click security to set NTFS permissions. The user you are logged on as must have permissions to change permissions. You should use an account with administrative priveledges. When you install the printer, install it as LOCAL printer. The printer you are installing is locally on your pc. The printer and print device are 2 separate things. Share the printer, and give certain Groups with the user accounts added to them the necessary permissions to print, manage documents, or manage printers in the security tab of the printer properties dialog box. The reason you can view the hd from the ME machine is because by default all users are members of the Everyone group, and the everyone group has read, read & execute, and list folder contents permissions. Create a group to put users in and right click on the whatever folder, drive, printer, or object that has been shared and go into the security tab and add the group to the list. Next check the Allow boxes for the permissions you want users in the group to have for said object or folder (try not to issue permissions to files, if you must then it is a good idea to put those files into folders and give permissions for the folder). If you do not want some certain users to have as many priveledges to certain things as others, then just deny them certain permissions, or better yet add them to a different group and simply do not grant them those permissions.

-=jonnyrotten=- <_<
  • 0

#3
fuoleum

fuoleum

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
<_<

I'm not sure either I understand you or you understood me !!!

I've re-read my message and there are certainly some things that aren't clear...

My "network" is set up. I have a workgroup containing the two computers (let's call them XP and ME). This is visible from either PC.

The printer is installed locally on XP and shared. However on ME, although I can "see" XP in the workgroup, I cannot explore it - or access the printer connected to it. There is no option for me to right-click on the XP item and set any permissions. I only have COLLAPSE, EXPLORE, OPEN and PROPERTIES. Properties just has general info and no option to set anything. The only thing I can set sharing rights on is the printer (which is set) and various folders on the hard-drive (or the entire hard-drive) again this is set and visible from ME.

I also have a crappy printer on ME which is visible and connectable from XP!

XP is my best computer and is the host. I do not log on to either computer - and so do not log on to any network... I just turn both PCs on and Windows loads. On XP my name is 'Owner' and I have administrator privileges. 'Guest' is turned off.

I just need to give the computer "ME" the right to access the computer "XP" in the workgroup - but I don't know how. I've even ran Network Wizard again!

Many thanks to anyone that offers any more possible (or definite) solutions!

Al
  • 0

#4
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Well you're right about not having the security tab in ME, because ME does not have that tab, but If you go to your XP computer and click the security tab in the properties dialog box then you should be able to add users. If there is no security tab then go to My Computer, folder options, click the view tab, scroll to the bottom of the list and uncheck the box next to simple file sharing and then you should have the security tab in xp.

-=jonnyrotten=-
  • 0

#5
fuoleum

fuoleum

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
I haven't got an option about simple file sharing!! What's wrong with my software?

My last three options (just to prove I'm in the right place) are:-

- Show control panel in my computer
- Show encrypted or compressed NTFS files in colour
- Show pop-up description for folder and desktop items

Just in case you were wondering, this is a factory supplied Compaq that already had XP installed! It's not my fault (I don't think!)

<_<
  • 0

#6
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
You must windows xp home. You cannot disable simple file sharing in windows xp home edition. But,,,,when boot in safe mode simple file sharing is disabled for administrative purposes. You can assign permissions that way. Just boot in safe mode and then you should have the security tab.

-=jonnyrotten=- <_<
  • 0

#7
fuoleum

fuoleum

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
This doesn't work either...

When boot in safe mode, there is no network, so I can't right click on my XP PC in the workgroup to give permissions... coz it's not there!

But you were right about me having XP Home.

Any other suggestions, other than buy XP Pro?

<_<
  • 0

#8
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Xp pro is a good idea, but not fully necessary. The first thing to remember is you need to set the permissions for the ME computer from the XP computer. Boot in safe mode with your xp pc. Go to your printer, folder, drives, etc ... whatever you want to share and right click on it click properties and click the security tab, next try giving the everyone group full control, because by default the everyone group only has read permissions, hence the reason you cannot open anything from the me computer. The xp pc has administrative priveledges as you said and has full control by default. That is why you can do anything you want to the me machine from xp. All users are members of the everyone group, so to make sure everyone has full permissions the everyone group can be assigned full control. Not the best idea, but if you trust everyone using it then go ahead. At least try it for now to check if it works.

-=jonnyrotten=-
  • 0

#9
fuoleum

fuoleum

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
Hey jonny,

I'm afraid it looks like it can't be done properly...

I booted in safe mode, as you said and selected all the drives and stuff I wanted to share and gave full permissions to "EVERYONE". But I still had a couple of problems:-
1) In safe mode, there are no printers, so I couldn't share that with ful permissions
2) From windows explorer if you go to My Network Places>Entire Network>Microsoft Windows Networking>Group, then I can see two PCs - XP and ME. Right click and properties just gives me a general information box, with no tabs. Nor is there any security or sharing choice when I right-click.

Even with full permissions on the entire harddrive ME still gives me an "do not have appropriate access rights" type error when I try to browse XP. This is despite being able to network the drive and view it as part of "my computer" on ME.

So if I try to install a network printer by browsing for it (on XP) I cannot do it.

I may have come up with a rubbish workaround though... if I just type in the network address i.e. \\XP\PRINTER then I seem to be able to print to the printer. The problem is that it takes about 10-15 minutes to come out after pressing print on ME!

Thanks for your help (and patience) on this one. If you've got any more ideas I really would appreciate them, but if you're clean out I'll understand!

Could you tell me how to make a donation to thank you guys for your help?

All the best

<_<
  • 0

#10
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
I will check out some new ideas today as I am around people who will probably have an answer, or at least a new idea, and i'll get back to you.

-=jonnyrotten=-


In response to your wanting to donate click here
Donations Thank you for your support. <_<
  • 0

Advertisements


#11
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
I may have figured this out. Do you have service pack 2 installed?

-=jonnnyrotten=-
  • 0

#12
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
If you have SP2, printer sharing is turned off by default. Go into control panel and there should be some sort of security options either in the control panel, or in performance and maintenance. Not sure where exactly (i don't have sp2). You can then get into your windows firewall settings and enable printer sharing. I hope this works for you. let me know.

-=jonnyrotten=- <_<
  • 0

#13
fuoleum

fuoleum

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
I do have SP2. In Control Panel there is a "Security Centre". In here there is "Windows Firewall". In here there is then the option to allow "File and Printer Sharing". I'm afraid this option was already ticked. <_<

So no cigar again unfortunately, but thanks again!
  • 0

#14
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Don't give up yet. Check to see if there are any new drivers for your printer online. Check for windows xp, and especially for ME. Install those on each machine. To enable client computers running other Microsoft operating systems other than XP, to print to a shared Windows XP based printer, you must manually install a printer driver on the client computer. Then right click on your printer in XP and click sharing then click the additional drivers button and look at the list, the box next to Windows 95, 98, and ME must have a check in it. You may have this all already dont, I'm just checking.

-=jonnyrotten=-

Is your printer hooked to your computer with a LPT1 connection or TCP/IP?
  • 0

#15
fuoleum

fuoleum

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
That wasn't done, but installing the drivers didn't do anything... it still takes about 10 mins to print from the ME machine.

The printer is hooked up to the XP machine via USB.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP