Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

Have no ringtone on incoming calls , tried all sound problems to no avail, everything was ok till last update , any help please in plain language as a pc thickie running windows 8

Many thanks 


  • 0




    GeekU Junior

  • GeekU Junior
  • 608 posts

Someone over at the Skype forums solved it with the following:

If you go to Tools -> Options -> Sounds, what is the text in the button just below the “Play this sound” item? The correct should be “Mute all sounds”. If it is saying “Enable all sounds”, then this actually means that the sounds are muted.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP