Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Exasperating XP LAN problem


  • Please log in to reply

#1
hacksterbaby

hacksterbaby

    New Member

  • Member
  • Pip
  • 5 posts
Hi, new guy here. Problem's driving me crazy.

I have two laptops connected with a crossover cable. Some time back I had them LAN'd together with no problems, but something's gotten into the woodwork.

I run Network Setup Wizard on #1, and create a setup disk for #2. File and printer sharing turned on, everything done right. Everything appears to set up fine, but neither computer gets a ping response from 192.168.0.1, which ipconfig run on #1 shows as #1's LAN address.

#1 is connected to broadband via wireless adapter, and #2 can access the Internet through #1's connection just fine, but it's like #1's 192.168.0.1 address is "cloaked" from both itself and #2. When I use #1 to ping #2, #2 responds fine. So the problem is obviously with #1.

Internet's not a problem, but I need to be able to transfer files between the two as I was able to in the past. Any help appreciated-- I'm running out of hair to pull out.
  • 0

Advertisements


#2
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
If you have internet connection sharing enabled, it turns on IP Routing which usually prevents ping to that host. Just a guess.

Greazy Mcgeezy
  • 0

#3
hacksterbaby

hacksterbaby

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Thanks Greazy, but it's more than a ping problem-- they don't see each other or each other's shared folders on the LAN. I can't map the other's network drive on either computer.

According to a troubleshooter I ran somewhere (may have been on the MS site), both machines should be able to ping both each other as well as themselves. The troubleshooter hit a dead end after that.
  • 0

#4
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Any new firewalls recently installed? Maybe service pack 2 with Windows firewall?

-=jonnyrotten=- :tazz:
  • 0

#5
hacksterbaby

hacksterbaby

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
JR,

SP2 installed on both machines, but Windows firewalls are turned off since I run Norton Internet Security.
  • 0

#6
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
Make sure that your home IP address range is placed in the Norton Internet Security Trusted Zone or the equivalent to it. Also if that does not work then try to disable the firewall completely and try that.

-=jonnyrotten=- :tazz:
  • 0

#7
circular

circular

    New Member

  • Member
  • Pip
  • 1 posts
Thank you jonnyrotten! I registered *just* so I could post a big sigh of relief.

I've struggled for weeks with a Win XP Pro PC that would not answer pings from any other host on a local LAN, unless that LAN was numbered 192.168.2.x, which was the first netnum the Win XP PC saw. Then I changed to a Linksys router (for unrelated reasons) whose DHCP server only serves host numbers out of 192.168.1.x, and suddenly my Win XP PC wouldn't respond to pings. It could ping every other host, and every other host could ping each other, and everyone could reach the Internet. As soon as I renumbered the network 192.168.2.x (statically or with DHCP), my WinXP PC answered pings again, but only if numbered 192.168.2.x (not .1.x, .3.x, nothing). Windows firewall off, Ethernet driver updated, routes and ARP tables checked, bytes in confirmed, hours spent on the phone with Dell support, nothing.

In desperation I started perusing bulletin boards, hoping to find one competent enough to post my question to, and then I stumbled across your comment about checking Norton Security **or equivalent** -- in this case, McAfee. Whaddya know, a personal firewall, with a list of acceptable netnums, which contained only 192.168.2.x, apparently automatically installed upon initial setup.

FINALLY, after struggling for weeks, jonnyrotten's hint solved a very frustrating problem! Ironically, I perused this thread because of the word "exasperating" in the topic -- that rang too true.

Thank you thank you!

- circular reasoning (but not a host guy)
  • 0

#8
hacksterbaby

hacksterbaby

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts

Ironically, I perused this thread because of the word "exasperating" in the topic -- that rang too true.

Thank you thank you!


For what it's worth (and it's not), I'm still exasperated. Tried everything suggested herein. I've run the most recent updates of AdAware, Spybot, Registry Mechanic, CCleaner, Webroot SpySweeper, Xoftspy, and of course NIS/NAV (and yes, I've paid for and registered everything that requires such). I've trusted, allowed, exempted, disabled firewalls, and whatever, for both machine's addresses on the other machine (per IPCONFIG). It don't work. Period.

I've resigned myself to having to swap the printer's USB cable from one notebook to the other, and having to email (or burn CD's of) files I want to transfer. Also bought an external drive to back up "My Docs", just to be on the safe side.

[bleep].
  • 0

#9
Greazy

Greazy

    IT Professional

  • Member
  • PipPipPip
  • 277 posts
Ok, well tell me this, are your PCs IP addresses automatically assigned or manually? If manual, you may want to go to the WINS tab under the Advanced properties for your Network adapter and ensure that NetBIOS is set to "Enable NetBIOS over TCP/IP, and on the normal properties for the adapter, make sure you have the "Client for Microsoft Networks" installed and checked in addition to the "File and Printer Sharing", and the "TCP/IP Protocol".

This should at least make them see each other when using a browser to find them.

Greazy Mcgeezy
  • 0

#10
hacksterbaby

hacksterbaby

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Holy crap. It's fixed. It was NIS 2003 after all.

Greazy, everything was already configured as you described in your last post.

Johnnyrotten, for some reason, when I was floundering around before and tried the firewall solution, turning it off made no difference. Somehow whatever the problem was outside NIS has gotten fixed, because today, when I turned off the firewall, sure enough, 192.168.0.1 saw itself on the network, as did the other machine.

I'd already tried adding addresses to the trusted zone individually, and as a range. But regardless, 192.168.0.1 remained invisible on the network when the firewall was turned on. Today, just on a lark, I tried entering the addresses as network addresses along with subnet mask (option 3 in adding addresses to the trusted zone).

Voila. It works with the firewall now. :tazz:

Thanks for the help, guys.
  • 0

#11
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts

Holy crap. It's fixed.  It was NIS 2003 after all.

Greazy, everything was already configured as you described in your last post.

Johnnyrotten, for some reason, when I was floundering around before and tried the firewall solution, turning it off made no difference.  Somehow whatever the problem was outside NIS has gotten fixed, because today, when I turned off the firewall, sure enough, 192.168.0.1 saw itself on the network, as did the other machine.

I'd already tried adding addresses to the trusted zone individually, and as a range.  But regardless, 192.168.0.1 remained invisible on the network when the firewall was turned on. Today, just on a lark, I tried entering the addresses as network addresses along with subnet mask (option 3 in adding addresses to the trusted zone).

Voila.  It works with the firewall now.  :tazz:

Thanks for the help, guys.

View Post


Very happy to hear the awesome news! ;)

-=jonnyrotten=- ;)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP