Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

AMD Graphics, older system


  • Please log in to reply

#1
tdokl

tdokl

    Member

  • Member
  • PipPip
  • 11 posts

Hi, I've built a system out of parts I have.

 

GA-MA790GP-DS4H (w AMD Athlon 2.9GHz)

128Gb SSD

6Gb DDR2 (2Gb 1066, 4Gb 800)

 

LinuxMint KDE 17.1

 

The problem is getting video cards to work.

 

ASUS RADEON R5 230 2Gb DDR3

 

ASUS EAH5450 1Gb DDR3

 

What I want is to have a monitor and mouse in front of my treadmill and also at the computer where I am now.

 

On the treadmill I just use the mouse to select a Virtual Walk to show on the screen which I turn off when not in use.

 

What I get is (when just plugging things in, setting bios to fail safe, loading default Mint) is that the second screen is black and seems to be a part of the first where I get the desktop but programs open in the second and if I drag them to the first and full screen them they hop over to the second ???

 

help. I suspect I'm doing something fundamentally wrong like incompatible components choosen out of ignorance.

 

edit add : ,,and typos etc,

 

It might help to know the two monitors are different res and Hz.
Both video cards have three outputs, vga, dvi and HDMI and I'm using the VGA outputs.
I've tried using the onboard as one of the monitor inputs but the same thing happens.
I have a couple of 512Mb cards that I haven't tried, but I have found in the past that for viewing HD streams the videos continually clip off with less than 1 Gb video ram.


Edited by tdokl, 26 January 2016 - 07:02 PM.

  • 0

Advertisements


#2
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

Hello tdokl,

Unfortunately I can't help you with this issue but I do have some information which might interest you.
I have a couple of different versions of linux mint so I thought I would give them a test and see what happens.

My results were:

Linux Mint KDE 17.1 - Had exactly the same issue you have described.
Linux Mint cinnamon 17.1 - Multi monitors worked as intended.
Linux Mint cinnamon 17.2 - Multi monitors worked as intended.
Linux Mint KDE 17.2 - Second monitor had no wallpaper but programs were opening on primary monitor which was a good sign.

 

I would recommend downloading cinnamon or a newer version of KDE, putting it on a USB and trying it before installing it. These were the results I got they may be different for you just thought you might of been interested in my results.


  • 0

#3
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

Hi Nyser.

That seems very helpful, thank you.

I will try upgrading to 17.2 KDE (next weekend) and if I get the result you have I'll assume it's a bug being ironed out and stick with KDE for now. I'm used to it, though I'll check Cinnamon out to see if I want to change.

 

If I get it so that programs open on the primary monitor (incl staying there when fullscreened) I'd be happy.


  • 0

#4
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

I don't blame you its hard to change when you have found a distro that you like, I had some free time so I installed KDE 17.1 on another hard drive and mucked around with it, there is a couple of things you can try.

 

 

Check Display settings

 

Have a play around with the layout of your monitors when my primary monitor wasn't on the left side all the programs opened on the non-primary monitor.

  • Click the Start button located in the bottom left corner.
  • Mouse over Computer.
  • Click System Settings.
  • Click Display and Monitor.

 

Change placement to under mouse

 

This will make it so everything opens under your mouse pointer

  • Click the Start button located in the bottom left corner.
  • Mouse over Computer
  • Click System Settings.
  • Click Windows behavior.
  • Click Windows behavior located on the left.
  • Click the Advanced tab.
  • Under Placement choose Under mouse.
  • Click Apply.

 

 

Hopefully one of these will fix the window placement issue. For me to try and fix the issue regarding full screen I will need to know what exactly you are playing that way I can try replicate the error and see if I can find a fix.


  • 0

#5
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

I've set, as suggested, the primary monitor on the left in desktop setup. Before, because they were physically located so, it was on the right.

With just that, the primary monitor works.

Also, when fullscreening in either monitor the program stays where it is (I use various youtube vids). To get the window onto the secondary I need to drag it there but at least it is all functional once that's done so I don't have to plug-unplug monitor cables.   Thank you.

The only improvement on this (for me) now would be a full 'mirroring' of the desktops with ability to launch programs from the secondary monitor without going to the primary.

 

edit add :

 

I speak too soon:

 

I find I have to reset each time I start the computer or the setting reverts to the primary card becoming the secondary one AND the fullscreen goes to that one,

ie: when reverted: The log in screen (except for some bits of it) happens on the pc screen (PCIE slot 1).

The launchbar is on the pc screen but the mouse starts on the treadmill one (PCIE slot 2).

Programs start on the pc screen and stay there unless dragged except for the fullscreen which happens on the treadmill screen

when reset it works ok. (I understand not a true mirroring, but functional enough for this purpose)

Is it a configuration setting that doesn't take when pressing apply and needs to be set otherwise?


I also set the mouse placement as suggested, to no avail it seems.


Edited by tdokl, 27 January 2016 - 09:37 PM.

  • 0

#6
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

Unfortunately my knowledge is very limited when it comes to linux but I will help you the best I can.

 

 

I would just like to ask you a couple of questions.

 

1. So just to confirm you changed the monitor position in display settings and it was working as in intended, programs opening on the primary monitor etc..and after rebooting the settings weren't actually saved so it goes back to having the normal issues?

2. Would it be possible for you to try run both monitors from one card. For example: Try running both monitors from your Radeon R5 230 instead of having a separate GPU for both monitors.

 

 

To get the window onto the secondary I need to drag it there

 

It should be possible to make shortcut keys to move focused windows between monitors, I will have to research this but I believe it is possible.

 

The only improvement on this (for me) now would be a full 'mirroring' of the desktops with ability to launch programs from the secondary monitor without going to the primary.

 

I believe you want extended instead of mirrored, extended means that your second monitor is basically a extension of your 1st/primary monitor, I know what your asking I will have to research a bit for this one too.

 

 

 

 

First things first we need to fix the main issue which is the programs always opening on the non-primary monitor and the strange issue regarding the login screen being split in 2, once that is fixed I will help you with the above quotes.

If you could get back to me about the 2 questions above that would be great.

 


  • 0

#7
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

Thank's, I really appreciate the help.

Yes, and there's a bit more:

Now the savings don't stick at all. After setting the monitors in display settings and applying those settings the system logs out and I have to log back in to find that when I go back into system settings it's back to where the monitor off the card in PCIE2 (the EAH5450) (treadmill) is back on the left again and all the odd things are happening.


It seemed the setting worked fine for a couple of starting and running programs and then reverted and now refuses to do what it's told.

 

edit correction : the radeon is on PCIE1


Edited by tdokl, 28 January 2016 - 03:47 AM.

  • 0

#8
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

That's strange that nothing is saving I will do some research and see what I can find. Did you try with only one GPU?


  • 0

#9
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

No, I haven't.

 

I need to find a DVI to VGA dongle first.

 

I had thought of trying it but actually thought that given they are two different monitors (an ASUS VW193D (1440x900@60 or 75Hz) and a HP w185 (1366x768@60Hz)) with different res and Hz it wouldn't work (?). Also, wouldn't memory per monitor be less.? (remember, I'm not an expert at all)


  • 0

#10
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

I've upgraded to 17.3. After first start it's ok. Once I've opened a window in the treadmill screen it's back to no good. I'm thinking there is something about CrossfireX and the MB that causes a problem that software can't fix the way I want.
I'm going to temporarily install win7 so i can install the right catalyst drivers and see how that goes.

 

edit add : win7 enabled me to load the catalyst driver for the radeon and it works so it seems to me it's the linux driver that should be able to take care of this.

 

I'll switch back to mint and keep working on that.


Edited by tdokl, 30 January 2016 - 07:39 PM.

  • 0

Advertisements


#11
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

Upon reverting to Mint17.1 I found a driver that while not specifically for the radeon (for ubuntu 64bit) that seems to work better.

However, while the screens are now in the right configuration, plugged into repective monitors, the remaining problem is that now the secondary screen, when fullscreened (eg a video in you tube) it jumps from the secondary screen to the primary.

A bit of progress. It seems clear it is not an ubsolvable hardware problem.,,, phew.


  • 0

#12
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

Sorry for the late reply lost internet access because of all the storms where I am. I was going to suggest to install the AMD proprietary drivers but it seems like you have already fixed that problem so great.

 

Unfortunately I no longer have linux since my main computer isn't working at the moment so my instructions won't be the greatest.

 

However, while the screens are now in the right configuration, plugged into repective monitors, the remaining problem is that now the secondary screen, when fullscreened (eg a video in you tube) it jumps from the secondary screen to the primary.

 

I would suggest using Chrome instead of Firefox, load your desired video, fullscreen the video then press your hotkey to move the fullscreened video to your desired monitor.

Note: this might work with Firefox but I had mixed results when I tried it.

 

 

Step 1 - Install chrome.

  • Download and install chrome.

 

Step 2 - Set a hotkey to move window to other monitor

  • Click the Start button located in the bottom left corner.
  • Mouse over Computer
  • Click System Settings.
  • Click Shortcuts and Gestures.
  • Click Global keyboard shortcuts located on the left side.
  • Change KDE Component: to KWin.
  • Search for Window to next screen.
  • Click Custom then set your desired hotkey and click apply.
  • Try the hotkey you set and it should move this settings window to your next monitor.

 

Once that is done load your desired youtube video in Chrome, set it to fullsreen then press the hotkey you made to move the window to your second monitor.


  • 0

#13
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

Ok. I did that (while keeping firefox) and it works. Thank you.

If I fullscreen a browser window in the second monitor it jumps to the primary and then when I go to the primary monitor and press the hotkey it jumps to the secondary.

 

Similarlym if I open it in primary the hot key switches it.

Either way, (monitors size is different), the fullscreen keeps the size of the primary and doesn't stretch into, or fill, the sec.

However, a maximised browser window in the primary when switched to the sec. does stretch to fill.

Not ideal but definitely better.


  • 0

#14
Nyser

Nyser

    Geek in Training

  • GeekU Sophomore
  • PipPipPip
  • 227 posts

If I fullscreen a browser window in the second monitor it jumps to the primary and then when I go to the primary monitor and press the hotkey it jumps to the secondary.

 

Similarlym if I open it in primary the hot key switches it.

 

That is what the Window to next screen hotkey does it moves the window to which ever screen the window isn't on. There is another way which might suite you better.

 

 

Follow the instructions in post #12 again but instead of looking for Window to next screen look for Window to Monitor 1 and Window to Monitor 2(I'm pretty sure that is what it is called but don't have access to mint at the moment so if you can't find that look for something similar).

 

Instead of moving the window to what ever screen it isn't on it will move it to which ever hotkey you used. For example:

 

Window to Monitor 1 > Will move to primary / 1st monitor.

Window to Monitor 2 > Will move to second monitor.

 

 

I wish I could help you more but unfortunately I'm not that experienced with linux.


  • 0

#15
tdokl

tdokl

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts

I didn't find Window to Monitor 1 et.c. but Window to Screen 1 et.c. and Window to Desktop 1 et.c.. and will play around with them for a while. Thank you for all the assistance.
 


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP