Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Audio headset & speakers stopped working (Resolved).


Best Answer reach1 , 17 March 2016 - 09:59 PM

I got it working. Heres the thing though, I got the error before I even plugged in the USB sound card. I don't know why? Anyway I just restarted my pc and could now open pulse audio. Mayb... Go to the full post »


  • Please log in to reply

#1
reach1

reach1

    Member

  • Member
  • PipPipPip
  • 130 posts

Turned on my laptop and no audio. When I plugged in my headset I think I heard a faint crackling noise. Although the laptop speakers also stopped working. I booted another OS from my USB port and audio did not work in that.

 

If I plug my headset into the mic port, there is a thud noise so I know that has power but my headset port makes no thud noise.

 

 

 

This might help?

:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


:~$ lspci -v | grep -A7 -i "audio"
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
	Subsystem: Gateway, Inc. Device 0402
	Flags: bus master, medium devsel, latency 0, IRQ 10
	I/O ports at 1c00 [size=256]
	I/O ports at 1880 [size=64]
	Memory at e0100c00 (32-bit, non-prefetchable) [size=512]
	Memory at e0100800 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>

Edited by reach1, 04 March 2016 - 12:49 PM.

  • 0

Advertisements


#2
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

what operating system (os) is installed on your laptop and what other os did you boot to on the usb?

 

your device is showing up so to me that suggests everything is ok hardware wise except of course for the "Capabilities: <access denied>" part.

 

on my machine.

linux-4fcl:/home/suse13.2 # lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
        Subsystem: Gigabyte Technology Co., Ltd GA-EP45-UD3R Motherboard
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at fbff4000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel

so would guess it's a software/driver problem but need to know what os (64bit / 32bit) is actually installed on the laptop before doing anything.

 

:popcorn:

 

this might be the problem.

Disable module-switch-on-port-available it has been worked on for the pulseaudio 8.0 release but currently has a bug which makes the profile it switches away from unavailable, see https://bbs.archlinu...c.php?id=207868 as well

https://bbs.archlinu...603299#p1603299


Edited by terry1966, 05 March 2016 - 12:33 AM.

  • 0

#3
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

Hey terry, my os is xubuntu 14.04 "plus upgrades of course" 32bit and the same os was on the usb boot, cuz its my backup.

 

It sounds like that could be the problem but I really have no clue.

 

 

 

 

 

 

 

 

Can I do this or no?

https://wiki.ubuntu.com/PulseAudio

 

Troubleshooting

 

Resetting User Configuration

For some reason, pulseaudio's user configuration files can become corrupt(unsynced?) in some way, and deleting them (and forcing fresh ones to be generated) fixes a no sound condition. After using the command below, log out/in.

Ubuntu 13.04/Raring (and later)
rm -r ~/.config/pulse; pulseaudio -k

Edited by reach1, 05 March 2016 - 12:01 PM.

  • 0

#4
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

yes you can try that.

 

use this command

killall pulseaudio; rm -r ~/.config/pulse; pulseaudio -k

https://wiki.ubuntu.com/PulseAudio

 

then completely shutdown the laptop, remove the battery and power cable, hold in the power on button for 10 seconds then reconnect the battery and start the laptop and see if you have sound (removing all power probably not needed but is the way i like to make sure of things.).

 

just out of curiosity did this problem start after you'd just done an update, if so and above didn't fix things check if you have any more updates and install them too.

 

if still no sound try the fix from last post here :- https://bbs.archlinu...c.php?id=207868

 

For the moment I have made a workaround based on the comment #5 by Alexander in the referenced upstream report, and edited /etc/pulse/default.pa to comment out the line:

#load-module module-switch-on-port-available

just put the # in front of the line

load-module module-switch-on-port-available

in the /etc/pulse/default.pa file.

 

:popcorn:


Edited by terry1966, 05 March 2016 - 04:11 PM.

  • 0

#5
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

This is what happened?

 

 

400VTX:~$ killall pulseaudio; rm -r ~/.config/pulse; pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such process
 

I also tried my first code and nothing happened.

 

I think there was a small update, It could be from one but I don't know.

 

 

So i have to "Disable module-switch-on-port-available" in the pulseaudio folder, by using a terminal and opening the folder in AbiWord or Notes, then deleting "module-switch-on-port-available" and then saving the file... correct?

 

If so I need root privileges, I forgot how to get that.

 

The whole terminal command thing is confusing on what commands I need to do.


Edited by reach1, 05 March 2016 - 05:05 PM.

  • 0

#6
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

ok skip the killall and use the command as supplied in link. don't know why pulseaudio doesn't seem to be running on your machine.

 

 

rm -r ~/.config/pulse; pulseaudio -k

 

:popcorn:


  • 0

#7
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

 

I also tried my first code and nothing happened.

what do you mean by nothing happened?

 

when you type in

rm -r ~/.config/pulse; pulseaudio -k

and you hit enter it should just go straight back to the command line prompt.

meaning it completed the command with no problems, now you need to restart your pc.

 

or

 

do you mean when you say nothing happened that you entered the command restarted the pc and there was still no sound?

 

:popcorn:


  • 0

#8
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

or

 

do you mean when you say nothing happened that you entered the command restarted the pc and there was still no sound?

 

:popcorn:

 

Yeah it was a bust. no sound still.


  • 0

#9
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts


 

So i have to "Disable module-switch-on-port-available" in the pulseaudio folder, by using a terminal and opening the folder in AbiWord or Notes, then deleting "module-switch-on-port-available" and then saving the file... correct?

 

If so I need root privileges, I forgot how to get that.

 

The whole terminal command thing is confusing on what commands I need to do.

 

So, i need,

1. command to get root privileges

2. then command to open the correct file in lets say AbiWord

 

delete: "-*-detect load-module module-switch-on-port-available"

 

located at: "/etc/pulse/default.pa"

 

after that all i have to do is delete the above line from the file and save it.

 

Is that right?


Edited by reach1, 05 March 2016 - 05:48 PM.

  • 0

#10
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

 

So, i need,

1. command to get root privileges

2. then command to open the correct file in lets say AbiWord

 

delete: "-*-detect load-module module-switch-on-port-available"

 

located at: "/etc/pulse/default.pa"

 

after that all i have to do is delete the above line from the file and save it.

 

Is that right?

no don't delete anything.

 

the line will say

 

detect load-module module-switch-on-port-available

 

then just put a # in front, which means this line is to be ignored because it is now a comment line.

 

so the line will then look like this

 

#detect load-module module-switch-on-port-available

 

then save the changes.

 

and restart machine.

 

what desktop are you using? i'm going to install xubuntu to help me better guide you.

 

:popcorn:


  • 0

Advertisements


#11
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

I'm on my desktop with no sound, xubuntu 14.04 32bit, laptop.

 

ok, I understand what to do but I just don't know the terminal commands to open the file.

 

When I open the file from file manager I can edit it but it does not allow me to save the file.

 

It tells me

Failed to save the document

permission denied


  • 0

#12
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

I realized abiword may not work, so I installed leafpad.

 

 

the code: leafpad /ect/pulse/default.pa

will open a blank page in leafpad, thats as far as I got.

 

I tried opening the file in leafpad and it wouldn't save.


Edited by reach1, 05 March 2016 - 09:30 PM.

  • 0

#13
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

ok that's a permissions issue and you will need to open the file as a superuser but i'm still trying to find my way around xubuntu and not sure what apps it uses to do things yet so while i play around with xubuntu can you do something simple and open your sound settings and tell me what the playback volume is set to, then check the output devices tab and tell me what options you have under port if any and what it's set to and finally under the configuration tab tell me what profile options are listed and which one it is actually set to now.

 

:popcorn:


  • 0

#14
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,004 posts

ok to edit the /ect/pulse/default.pa file use this command to open the file with mousepad as a superuser from the terminal.

sudo mousepad /ect/pulse/default.pa

you will then need to enter your password.

 

now you will be able to edit and save the changes.

 

:popcorn:


  • 0

#15
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

playback 16%

output      16% and port headphones/amplifier

configuration options

analog stereo duplex <-- set to this one

analog stereo output

digital stereo output and analog stereo input

digital stereo output

or off


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP