Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

ACPI invalid _PTC data


  • Please log in to reply

#1
reach1

reach1

    Member

  • Member
  • PipPipPip
  • 130 posts

 Help me figure this out please.

 

 Gateway400vtx

Pentium 4

855gm graphics

 

 

I get this message "ACPI invalid _PTC data".

 

PTC stands for Processor Throttling Control.

 

Does this mean my processor memory is corrupt?

 

I am getting cpu/gpu rendering hangs.

 

Sometimes when I scroll up/down in any browser it delays.

 

Sometimes when I mouse click it does not register or delays.

 

I am getting that invalid ptc message and then cpu pipe errors when I try loading os's in bios from a usb

 

When I load up my os ubuntu 12 I get a broken pipe message, but it still loads.

 

I am trying to find what the source of the problem is.

 

If anything would make it easier, like getting a xp disk or what ever please let me know.


Edited by reach1, 02 April 2016 - 09:25 AM.

  • 0

Advertisements


#2
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,011 posts

to be honest i'd forget about using ubuntu 12 because it is so old and install the newest, then upgrade to ubuntu 16.04 LTS when it comes out in a couple of weeks. (21st april 2016.)

 

see if using the newer distro fixes the problem.

 

from my understanding it might be caused by an acpi bug in the bios so doing a bios update might fix it if running the newer distro and kernel doesn't.

 

:popcorn:


  • 0

#3
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

 Ubuntu 14 is to heavy, thats why I have 12, I don't know about 15 or 16. I might just try updating to 14 - 16 to see if there is a bug fix.

 

If that does not work maybe I'll try and get another hard drive and start from a clean format.

 

It does seem like a bug, everything still works but it just works badly.

 

Its like my cpu does not pace its self and all the data gets bottle necked, then it all gets released at once.


  • 0

#4
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,011 posts

you can always try booting with acpi set to off.

 

just add

acpi=off

to boot loader.

 

full instructions on how to do that in link :- http://askubuntu.com...pi-when-booting

 

:popcorn:


Edited by terry1966, 04 April 2016 - 12:34 AM.

  • 0

#5
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

That seemed to help.

 

I did step 4 first but that did nothing.

 

Second there is a mistake on that page. To open the GRUB menu one must hold down the shift key. I must of tried ten times to only press shift, it would tell me it was loading grub menu but then it would only start up the os. :bashhead:

 

I added acpi=off to the end of that command line. That got rid of the error message. :thumbsup:

 

It does look as if it is working better, for the most part. Of course its not working as good as it was when ACPI was working.

 

I really wish there was a program that I could use that would read that ACPI and other files so I could just correct the problem. :idea:

or even if I could just read up on it.

 

Thanks, geekstogo is by far the most helpful :cheers:

 

I should add, before I turned acpi off, I noticed my laptop was running a little hot even with a extra cooling fan. Hopefully turning acpi off will stop my cpu from going on a rampage, it should help at least.


Edited by reach1, 03 April 2016 - 09:12 AM.

  • 0

#6
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,011 posts

you may want to try using lubuntu instead of ubuntu, that way you can have the latest kernel which should work without turning off acpi and also have a desktop that is much lighter so should work great on older pc/laptops.

 

http://lubuntu.net/

 

:popcorn:

 

 

I noticed my laptop was running a little hot even with a extra cooling fan.

give it a good blow out with compressed air to clean the dust out of it. eg :- http://www.howtogeek...of-your-laptop/

 

compressed air :- http://www.amazon.co...node=3012916011

 

taking note :-

 

Exercise caution when doing this. If you aim a blast of compressed air directly at a cooling fan inside a vent, you could cause the cooling fan to spin too quickly. Don’t aim the air directly at the fan and give it a long blast. Instead, blow air in short bursts, waiting in between to ensure you’re not spinning the fan too quickly.


Edited by terry1966, 03 April 2016 - 04:38 PM.

  • 0

#7
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

I tried lubuntu 14 usb boot and didn't really notice much difference, then I tried lubuntu 15.10 usb boot and I did notice videos lost less frames.

Both 14 and 15 and my current ubuntu 12 has the same freezing lag due to the acpi bug.

Lag or freezing or cpu rendering issues looked the same in all 3 because of that acpi bug, "exactly the same".

Lubuntu 15 is lighter and after I install it and turn "acpi=off" it should be even a little better that it is now.

Hopefully lubuntu 16 will be even a little lighter and have a bug patch.

 

Thanks again :thumbsup:


  • 0

#8
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,011 posts

to be honest i'm not 100% sure your problems are due to the acpi bug (and the fix for that is a bios update. the newer kernels just have a work around built in if my understanding is correct.) and are more likely caused because of your high cpu temps.

 

just for info on what acpi is and does. :- https://en.wikipedia...Power_Interface

 

:popcorn:

 

another distro you might want to try that may offer you better performance on your old hardware is puppy linux :- http://puppylinux.or...ing Started.htm


Edited by terry1966, 04 April 2016 - 12:06 AM.

  • 0

#9
reach1

reach1

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 130 posts

Thanks for that link. So basically acpi is a program that allows a OS to control power or voltage(through acpi) to the RAM and CPU. In my case (Pre 2004) acpi was designed to specifically work for the windows xp OS that was originally installed. So, I would think my OS is asking the acpi to help out the CPU and RAM with voltage but since the apci is broken it just kinda stalls out and it forces other components to make up for it.  Also since my laptop is integrated, it would probably make it even harder without the correct acpi configuration.

 

 

I did try out puppy linux LXDE but it didn't work very well. I did not try it with acpi=off setting though.

Lubuntu 15.10 is working well enough now.


  • 0

#10
terry1966

terry1966

    Member 1K

  • Member
  • PipPipPipPip
  • 1,011 posts

 

Lubuntu 15.10 is working well enough now.

:spoton:

 

:popcorn:


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP