Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

error code 80041003 -CIMWIN32.Mof ? Just can't seem to fix per mi

corrupt WMI --

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 7 posts

I thought I had a corrupted program / file / folder and for 8 months now I have tried every thread I found on not a valid win32 application - then Sunday night I finally found it -in a addition.txt report - it is microsoft/windows  application error - 


** error Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.


so all this time it was a Microsoft update - s originated in the Windows 7 SP1 DVD/ISO creation process. There was an issue in the creation process that caused a WMI registration to remain in the DVD/ISO. Since the registration is designed to work only during the DVD/ISO creation process, it fails to run on a live system and causes these events. These events are not indicative of any issue in the system and can be safely ignored. If however you want to prevent these events from getting generated and want to remove this specific WMI registration manually, please follow the steps mentioned in this article for running the workaround script


tried all this today 6 hours and still can't get it fixed - command says not right path 

Powershell said not correct  path not found - everything I tried fail  -


here is first thing I tried -

 Set OSBIT=32

IF exist "%ProgramFiles(x86)%" set OSBIT=64
set RUNNINGDIR=%ProgramFiles%
IF %OSBIT% == 64 set RUNNINGDIR=%ProgramFiles(x86)%
subinacl /subkeyreg 
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing" /grant="nt service\trustedinstaller"=f



  • 0




    Trusted Helper

  • Malware Removal
  • 4,924 posts



The error you found on the Windows Event Viewer is not related with the error "not a valid win32 application"


According to Microsoft the event ID 10 is not important it can be ignored or removed by following the instructions available here before Microsoft decided to remove most of the FixIt utils one existed to fix this problem automatically called MicrosoftFixit50688 that can be yet downloaded here.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP