Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Keyboard works in BIOS, but not Windows.


  • Please log in to reply

#1
Mayuzda

Mayuzda

    New Member

  • Member
  • Pip
  • 1 posts

After extensively searching the internet for solutions and trying various 'fixes', I've decided to post my issue on here as the problem has beaten me.

So I booted my computer on the 19th of October and as I am halfway through typing my password into Windows, my keyboard stops 'working'. I check to see if its a hardware issue and plug it into my laptop. The keyboard is perfectly fine. So I reboot and try again noticing how the numlock turns off as Windows loads. 

 

I have tried uninstalling the keyboard drivers so that they would reinstall them, however this has made it so I now have no keyboard tab in the device manager now and no HID Keyboard driver. I have also tried fixing the problem in two different ways in regedit. One by adding the missing UpperFilters file and the other method was suggested by Windows online help which in short then also prevented my mouse working (was to delete a certain file), until I restored it in the F8 menu to a restore point.

 

Here is a snapshot of my computer (http://speccy.pirifo...Hf0tVSkCVHqamUW), which also doesn't show a keyboard.

 

I've probably missed somethings out and any help would be appreciated  :D  


  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 21,189 posts
  • MVP

Does it perhaps work in Safe Mode with Networking?

(Reboot and when you see the maker's logo, hear a beep or it talks about F8, start tapping the F8 key slowly.  Keep tapping until the Safe Mode Menu appears and choose Safe Mode with Networking.  Login with your usual login.)


 

 

Have you tried SFC?

 

Start, All Programs, Accessories then right click on Command Prompt and Run as Administrator.  Then type (with an Enter after each line).

sfc  /scannow

(This will check your critical system files. Does this finish without complaint?  If it says it couldn't fix everything then:

Copy the next two lines:

findstr  /c:"[SR]"  \windows\logs\cbs\cbs.log  >  %UserProfile%\desktop\junk.txt
notepad %UserProfile%\desktop\junk.txt

Start, All Programs, Accessories, right click on Command Prompt and Run as Administrator, Continue.  Right click and Paste or Edit then Paste and the copied line should appear.
Hit Enter. Copy and paste the text from notepad or if it is too big, just attach the file.)

 

 

Since you seem to be able to get on somehow can you run Windows Repair All in One?

 

http://www.tweaking....all_in_one.html

the portable download is a zip file so you have to save it then right click and Extract All Extract.  Then open the folder and right click on Repair_Windows and run as Admin.

They offer various canned checked options but

 

we only need the following checked:

 

Reset Registry Permissions
Reset File Permissions
Register System Files

 

before hitting Start.  Reboot when done.  See if it helps.

 

You can also try installing a newer version of the Intel Chipset software:

 

https://downloadcent...llation-Utility

 

Or try  one from ASUS support


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP