Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem with XP Home SP2 firewall settings greyed


  • Please log in to reply

#1
Nocturnal

Nocturnal

    Member

  • Member
  • PipPip
  • 44 posts
I have a computer that has WinXP Home with SP2 on it. Basically I removed some spyware or virus which messed with the registry setting for the Windows Firewall. Now when I go to the firewall settings, enable and disable are both greyed out. I can manually turn on and off the firewall through the registry settings however I canít seem to fix this problem with both boxes being greyed out. It says something like it is being managed by a group policy but the thing is, there is no group policy within WinXP Home.

Iím dying trying to figure out what the [bleep] is going on and how to fix this problem without formatting the computer.
  • 0

Advertisements


#2
h1ppy

h1ppy

    Member

  • Member
  • PipPip
  • 22 posts
Have you tried logging in as administrator to change the firewall settings, and do you have any other software firewall running?
  • 0

#3
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
start > run
regedit
enter

navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

anything in there sound like a firewall setting?
  • 0

#4
Nocturnal

Nocturnal

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
Yes there are a bunch of stuff in the Policies area.
  • 0

#5
Nocturnal

Nocturnal

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
For future reference what I had to do was delete these two keys from the registry: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\DomainProfile

and

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsFirewall\StandardProfile

Those two keys are not needed for Windows XP Home.
  • 0

#6
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
ahh, thanks for the update....sorry I never got back to you and it looks like you found the proper settings.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP