Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

tagan 480 problems

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
hi, im ViegeBeer and i ran into some problems with my psu, i got it from a friend of mine, in his computer it ran properly, he had a 64 bits system, i have an amd xp 2600 on an asus a7n8x deluxe, which didnt bring me any problems with my noname psu but with this tagan 480, it starts ... well ... the powerled lights up and the fans are spinning, just like my hdd is running, but there is nothing on my screen, so if anyone is fermiliar with this problem, please help me i dont what to do with it anymore, thnx alot !!!
  • 0




    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi and welcome to Geeks to Go. I checked my favorite link on power supplies at http://www.hardforum...ad.php?t=792566 and Tagan is ok. It may be that you don't have all of the cables properly connected? Start by checking those. Did you get a manual with the PSU? You may be able to get one from the manufacturer web page.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP