Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Internal modem problem


  • Please log in to reply

#1
Mrs Jones

Mrs Jones

    New Member

  • Member
  • Pip
  • 9 posts
I am using a Toshiba Armada 1750 with a new hard drive on it and my husband has added XP for the O/S (not my first choice, lol). The laptop has been hooked up to the internet via the cable modem and the PC card...what I am trying to do is use it for work when I am on the road and that means dial up (ugh) The company has provided me with a "pay as you go" cd that allows a certain number of minutes to the web via dial up however after installation and trying to set it up it tells me my computer does not have a modem...however if I go throught the control panel it is recognizing the modem just fine and says that it is working - is it just a setting that needs to be fiddled with? Does XP need to be told where to look for the modem as it had already been used for cable? I hate to buy a new external dial up modem if all I needed was to click something off or on.


Thanks bunches!
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Is the modem built in or is it a pcmcia modem?

PS Do you mean you have a Toshiba Satellite 1750 (Armadas are made by compaq!)

Edited by Samm, 13 July 2005 - 05:03 PM.

  • 0

#3
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
It is an internal modem...compaq 56VL Global Internal Modem (attached to com4). The properties list it as working properly and it is enabled.
  • 0

#4
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
BTW.. ooops on the toshiba reference...that was my old lap top. You are correct that this is a Compaq Armada 1750 <must have more coffee NOW> :tazz:
  • 0

#5
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
OK, can you try this then, if you haven't already...
Go to control panel->Phone & modems option->modems tab
Click on modem to select it in list, then click properties->diagnostics->query modem.

After a few seconds, you should either receive a list of AT commands or an error message. Let me know whether you get AT commands (modem is OK) or the details of the error message.
  • 0

#6
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
I am getting the following...

Field Value
Hardware ID *CPQB05B

Command Response
ATQ0V1E0 Success
AT+GMM H.324 video-ready rev. 1.0
AT+FCLASS=? 0,1
AT#CLS=? COMMAND NOT SUPPORTED
AT+GCI? +GCI:20
AT+GCI=? +GCI:(09,0F,31,3C,3D,42,7B,59,7E,82,
A0,A5,A6,B4,0A,00,26,61,6C,9C
A9,54,8B,B5,57,50,20,73,53,BC,
89,46,51,AE,9F,8A,2E,69,16,1B
2D,52,B8,58,98,84,07,14,25,27,
35,85,88,BB,87,B7,8C,49,2B,7F
68,B3,B2,36,0E,48,62,8E,A1,83
0D,64,70,77)

ATI1 E49E
ATI2 Success
ATI3 LT V.90 Data+Fax Modem Version 5.98A
ATI4 70
ATI5 5.98A,0,1C
ATI6 Success
ATI7 Success

From your response it looks like the modem is ok...so I may have a setting problem with XP or my noggin...
  • 0

#7
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
OK, the internal diagnostic for the modem looks fine.
I realise that the system has been previously configured for broadband so have you created a new dialup network connection for the internet & configured it?
  • 0

#8
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
I have tried to no avail in setting up a new connection.

The wizard comes up and I chose "connect to the internet", next, set up my connection manually, next, then when the next screen appears the only option it is giving me to take is "connect using a braodband connection that is always on" (which I know I don't want)...what I think I need is "connect using a dial-up modem" though that option is greyed out and not available for selection....if I try to use the CD that the webminutes are on it tells me I don't have a modem....kind of a catch 22
  • 0

#9
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Using the troublshooter in XP I am wondering if perhaps the internal modem is not compatible with XP...though without getting a connection to the internet I can't check on the windows HCL like it wants me too...I thank you for your help though I am seriously considering putting 98 back in cuz I know that worked.....
  • 0

#10
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
OK, can you confirm that you have tried this :
control panel->network connections->create new connection
Then select 'set up connection manually' -> connect using dial up modem

Sounds like you have but want to be sure
  • 0

Advertisements


#11
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Have attempted to yes - however the option of setting up a dial up connection is greyed out and not available. As there is nothing on the laptop yet that can't be replaced I will attempted to do a reformat and reinstall XP...failing that I will try '98 as the modem may not be compatible with XP

Thank you again for help :tazz:
  • 0

#12
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Hi

The problem I believe is due to the fact that you have upgraded to XP from win9x. If you haven't already performed the fresh install, then try this :

Go to Start->Run and type regedit
Locate & click on the following key in the left hand pane:
HKEY_CURRENT_USER\software\Microsoft\Windows\CurrentVersion\Telephony\cards
When you've clicked on it, you should see an entry in the right hand pane called NextID.
If so, click on NextID to highlight it, then select Edit menu->delete, to remove to it.
Exit regedit & reboot.

Try & create a new connection again. IF the dial-up option is still greyed out, then try the next step :
run regedit again & relocate the above key :
HKEY_CURRENT_USER\software\Microsoft\Windows\CurrentVersion\Telephony

Click on telephony & delete.
Exit regedit & reboot. Try to create a dial-up connection again.

Let me know what happens, or if you have already reinstalled windows.
  • 0

#13
Mrs Jones

Mrs Jones

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
I'm afraid neither of the suggestions worked. I am going to try a new install of XP in the next day or so to see if that may help.

Thanks again!
  • 0

#14
cazabra

cazabra

    New Member

  • Member
  • Pip
  • 3 posts
HI ..
Hoping Samm might have more insight into this issue.

I have a 10 day old HP Pavillion notebook (dv1340us)
XP Pro came pre-installed and I have done nothing but install Outlook, Photoshop, Spyware Doctor, and ZoneAlarm Pro.

attached image shows reg with NextID removed along with a view of what the actual prob is.

Hyperterminal didn't even work (got busy msg)
Modem query had a line in it asking if the device was installed.

.. an HP tech recommended installing SP2 (though it is already installed) .. as he was confident missing items like the screenshot displays, were due to a corrupted SP2 install.
Did that.. didn't fix this problem but did fix the hyperterminal issue... (it started working after the SP2 re-install .. and query looked normal)

So I then tried the removal of NextID .. and rebooted .. nada
Removed telephony .. nada .. and now of course, I have no modem to query.

This is driving me batty :tazz:

note: i disabled ZAPro during all of these tests
.. have another hp notebook purchased a couple months ago that works fine .. but it is running HP Home

Thanks in advance for any ideas.

Attached Thumbnails

  • modem_ss.gif

  • 0

#15
cazabra

cazabra

    New Member

  • Member
  • Pip
  • 3 posts
weird :|
just after the above post, checked reg again and telephony is back along with the Cards > NextID
.. where did they come from :tazz:

dial-up option still greyed out though ;)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP