Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't find hard drive


  • Please log in to reply

#1
romedi

romedi

    Member

  • Member
  • PipPip
  • 15 posts
Hi!

I have a strange problem:
I have this hard drive that I have some important files on. When I start my computer, it is found by the bios.
But when I open "My Computer" in Windows XP it isn't there!
And even when I go to "Unit Handling" (Have the danish version, so I guess it is the english word for it), you can find it there, and you can even see, how much space there's left and other things.
Hope you understand my English.

Any solutions?

Thanks in forward.

- Romedi
  • 0

Advertisements


#2
warriorscot

warriorscot

    Member 5k

  • Retired Staff
  • 8,889 posts
Your english is better than most.
Is the drive set as the slave and not the master, assuming you are using another hard drive as your main drive.
  • 0

#3
romedi

romedi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
The hard drive is set as the slave, and the jumper is placed correctly as I have triple checked. Also with my master hard drive.
  • 0

#4
warriorscot

warriorscot

    Member 5k

  • Retired Staff
  • 8,889 posts
Have you tried it as the master.
  • 0

#5
romedi

romedi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Now I have. It didn't help. :tazz:
  • 0

#6
The_Sloth

The_Sloth

    Member

  • Member
  • PipPipPip
  • 160 posts
Put it as the slave again. Most likely what you need to do is assign it a drive letter, Windows probably knows it's there it just hasn't given you access yet. Here are the steps to check if Windows sees the drive and has given it a drive letter.

Click on Start then right-click on My Computer and select Manage. When the window opens click on Disk Management in the left hand column. You should see a list of all your connected drives on the right. Tell me if all of your hard drives are showing or not.
  • 0

#7
romedi

romedi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
It isn't shown in "the upper list", but it is shown in the list beneath it, and it has a status of "online".
But it has a black line, and it says it's "not-allocated" - not sure about the last word, as I have to translate danish computer phrases into english.
  • 0

#8
The_Sloth

The_Sloth

    Member

  • Member
  • PipPipPip
  • 160 posts
Ok, what you need to do is right-click on the drive and select Change Drive Letter and Paths. Another window will open. Click on the Add button in that window and Windows will bring up another window that will have a drop-down box listing available drive letters. Choose the one you want, click Ok then click Ok on the other window. You should be set after this. If you want to rearrange the drive letters on your CD-ROMs follow the same process, but click Edit instead of Add.

Please let me know if this fixes your problem, or if you're having trouble with the English to Danish translation.
  • 0

#9
romedi

romedi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
I don't have those options.

When I right click on the drive I get to choose between: "New Partition", "Properties" and "Help".
  • 0

#10
MOLEXRULZ

MOLEXRULZ

    Member

  • Member
  • PipPipPip
  • 346 posts
It could be a registry error. Go to Start, run and type the letter for the hard drive, either E: or F: or G: etc.. depending on wether you have 2 optical drives or more hard drives. Tell me what happens. Also what version of windows are you using and what formatting is the drive because NTFS isn't 2000 compatible.
  • 0

Advertisements


#11
romedi

romedi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
@ MOLEXRULZ

As written in my first post, the drive ins't nowhere to be found. I'm using XP sp2 and the hard drive is using the FAT32 system. I did what you suggested, and it's just saying, that the place I'm refering to, is not availble.
  • 0

#12
The_Sloth

The_Sloth

    Member

  • Member
  • PipPipPip
  • 160 posts

Also what version of windows are you using and what formatting is the drive because NTFS isn't 2000 compatible.

View Post


NTFS is compatible with NT, 2000 and XP...the only OS's that won't read it are ME, 98, 95 and anything before that.

romedi,

Here's something to try. Go to http://www.masterbooter.com and download the trial version of their software. Make a boot floppy out of it and reboot to that floppy. Run the efdisk utility on the disk and dig through the menus (unfortunately I forget how it's all setup) and unhide the partition on the slave drive. MAKE SURE NOT TO DELETE ANY PARTITIONS. After you unhide the partition, restart back into Windows and if it doesn't automatically pick up the drive do what I told you earlier to add the drive letter to it.
  • 0

#13
romedi

romedi

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Now I have a hard drive ;)

Just wanna say thank you to The_Sloth. Your help is much, much appreciated, as I now can buy a new graphics card instead of a new hard drive as I feared :tazz:

Thank you again ;)
  • 0

#14
The_Sloth

The_Sloth

    Member

  • Member
  • PipPipPip
  • 160 posts
No problem :tazz: ! I'm glad it worked out well for you.
  • 0

#15
MOLEXRULZ

MOLEXRULZ

    Member

  • Member
  • PipPipPip
  • 346 posts
If you need any advice on a videocard
id glad to help
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP