Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Extremely bad situation.

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 7 posts
I am trying to fix a computer that belongs to a friend of mine, i've been at it for the past couple weeks.

The original problem was that when windows loaded, no matter which option you chose (Safe mode, last good configuration, normal) the chkdsk would run, and eventually say that it could not read the windows security descriptors, and the computer would not boot past that.

Well, I followed some tutorials about the system recovery console, and one of them told me to remove the security system sam default and software files from system32\config and replace them with the ones in the windows\repair directory. I did this, but when i tried to copy the windows/repair/system file to the system32\config directory, it turned out that it dident exist.

So, I downloaded a live knoppix linux cd and looked through the directorys and instead there is a system.bak file in windows\repair. I have no idea what to do with this file, just thought i'd mention it.

Well, after that I thought it would make sense to copy the system file from my windows xp cd, the one i'm booting off of because my friend doesnt have her cd, into the system32\config directory. This appears to have been a huge mistake, because now whichever option I pick on startup it doesnt even load the chkdsk, it just reboots all together.

So, after that, I decided to [bleep] with it i'll just run a repair installation. I had tried this before, and it gave me this error:

Setup has determined that drive C: is corrupted and cannot be repaired.

Setup cannot continue. To quit setup, press F3.

But i tried again anyways today, just to see if it would work, and not to my suprise, I got the same error.

I would love some help with this, if at all possible I would like to avoid formatting the drive. I have been using Linux and my friends flashcard to transfer some of her files onto my computer, but this is a long and grueling process and i'd rather have the operating system fixed than have to move everything to my computer and then format, and then have her get a new windows xp installation, because the store she bought her laptop from did not come with a windows xp installation cd. I am willing to do that as a last resort though.

Thanks for your time. :tazz:
  • 0




    Retired Staff

  • Retired Staff
  • 11,365 posts
well...this is what I would do....I have a 2.5 inch harddrive enclosure I bought for $20 and i would pop the drive in there


then run chkdsk /r on it and see if that fixes it...


delete the partition and then create a new one and format it, then install windows on it
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Ah...some things I think I should have mentioned before-

I can no longer use the recovery console, when I start it up it asks me for an administrator password and her admin password doesnt work, so i'm at a loss there. And, I have absolutly no money, although I could get $20 if need be. Besides the computer is a laptop, i cant take the drive out, if thats what your suggesting, but i think i'm misunderstanding this first option.

As for deleting the partition and creating a new one, formatting it, and then reinstalling windows xp on it, you are right I could do that...but i'd really prefer not to. I'm not even sure how I would do it without recovery console either, i'm sure theres a way to do it with my knoppix live-cd but i dont want to get a headache trying to figure it out, the [bleep] thing dident even come with captive-ntfs so I cant just move the system file from my flashcard (which i took from my computers windows\repair directory) into her config directory because I cant write to the hda1 partition.

Are there no other options?

Edited by YoukaiHiei, 19 July 2005 - 08:39 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP