Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Dual Booting with XP


  • Please log in to reply

#1
Soldner

Soldner

    New Member

  • Member
  • Pip
  • 8 posts
Hi, I recently bought a new HD and would like the following:

When the PC boots, I would like it to give me a choice between booting to my old HD(with XP and other programs already installed) or to my new one(which has a fresh copy of XP on it...nothing else. I want XP on both of them...

is that possible?

If it is can someone please explain how I can make the selection as to which I want to boot to.

Right now the only way I can switch which one I want to boot to is to enter the bios and change which HD is the first choice...if I choose my old one...I boot right to that one...If I choose my new one....I boot right to that one. How can I get there to be a choice as to which one I want to boot to when the system starts up to avoid having to go through the bios.

Any help would really be appreciated

Edited by Soldner, 20 July 2005 - 08:00 AM.

  • 0

Advertisements


#2
splintax

splintax

    Member

  • Member
  • PipPip
  • 54 posts
Disclaimer! I'm not sure if I'm correct here, messing with this section of your hard disk can seriously mess with your setup so I advise you to wait for confirmation from another member first..

You need to edit your boot.ini file. This is found in the root of the hard disk that you boot from by default. Here's what mine looks like:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
Under [operating systems] you need to change the bit that says:
multi(0)disk(0)rdisk(0)partition(1)
If that's what you get I think you should change that to multi(0)disk(1)rdisk(0)partition(1). This should get it to boot from the main partition on the second hard disk. I strongly recommend, again, that you don't rush in and do this straight away, because I'm recalling it from memory and not sure if this is the correct process.
  • 0

#3
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Thanks, I'm glad I'm getting somewhere...I'll hold off on this until tonight.

Thanks again.
  • 0

#4
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Oh yea, I forgot to ask you...will I have to make these changes to the boot.ini file on both OS's or just one...for instance I edit them with notepad. I can open the boot.ini of the Win XP installed on my 1 harddrive and I can open the boot.ini of the Win XP installed on my second harddrive...I would assume I make them changes to both of them.

Thanks again for your help.
  • 0

#5
urichjones

urichjones

    Member

  • Member
  • PipPip
  • 45 posts
Can you post your current boot.ini text?
  • 0

#6
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Sure...here it is.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Hope that helps
  • 0

#7
urichjones

urichjones

    Member

  • Member
  • PipPip
  • 45 posts
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
multi(0)disk(1)rdisk(0)partition(1)\Windows"Microsoft Windows XP Pro 2nd Boot" /fastdetect

You can use the above in your boot.ini. Go to your C:\ and open boot.ini. Add the line in blue and the parts in green can be changed to anything you want to differentiate between the two drives. Save the file THEN:
1. click on the start button
2. click on run
3. type in msconfig
4. press enter
5. click the boot.ini tab
6. click "Check all boot paths"
7. If the check gives no errors you should be good to go! :tazz:
8. Jump up and down in celebration or pull out your hair in frustration. ;)
9. Login here and post your results
10. Have a good day! ;)

Seriously let me know if this helps!

Urich
  • 0

#8
nost

nost

    banned

  • Banned
  • PipPipPip
  • 102 posts
what are your hard drives set as master or slave
  • 0

#9
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Thanks for all your help...I'm going to edit my boot.ini and I'll be back (hopefully) with the results.

Both harddrives are on the primary channel, one is master, one is slave.

Be back soon.
  • 0

#10
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Howdy:

All you should have to do is install XP on the second hdd.. It should automatically adjust the boot.ini file in the c: drive to reflect the two installs.. No need to edit anything!!

Murray
  • 0

#11
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Ok, I edited the boot paths like urich reccomended. When the computer starts it allows me to choose either harddrive 1 or harddrive 2 (thats what I named them)

If I have my WD HD set as the primary HD then that registers as Harddrive 1 and if I have my Maxtor set as primary HD then that registers as Harddrive 1.

If I select to boot to HD 1...everything works fine. But then when I restart and select to boot to HD 2 I get the following message.

"Windows could not start because of a comp0uter disk hardware configuration problem

Could not read from the selected boot disk hardware"

I have now idea why this is happening. If I run msconfig and "check all boot paths" under the boot.ini tab it claims that everything is valid and there doesn't appear to be any errors.

Any suggestions would be more than appreciated.
Thanks to those who have offered help so far.
  • 0

#12
urichjones

urichjones

    Member

  • Member
  • PipPip
  • 45 posts
Here is a fix I got from Microsoft. You can read the entire page here.

Use the Bootcfg utility in the Recovery Console to correct the Boot.ini file:
1. Use the Windows XP CD-ROM to start your computer.
2. When you receive the message to press R to repair Windows by using the Recovery Console, press the R key.
3. Select the Windows installation that you want, and then type the administrator password when prompted.
4. Type bootcfg /rebuild, and then press ENTER.
5. When the Windows installation is located, the following instructions are displayed:
Add installation to boot list? (Yes/No/All)
[Type Y in response to this message.]

Enter Load Identifier:
[This is the name of the operating system. Type Windows XP Professional or Windows XP Home Edition.] (Name it something other than hard drive 1 or 2 so you can delete the wrong entries at the end. You can always rename them afterwards)
Enter OS Load options:
[Leave this field blank, and then press ENTER].
After you perform the preceding steps, restart the computer, and then select the first item on the boot menu. This should allow Windows XP to start normally.

After Windows XP has successfully loaded, the Boot.ini can be modified to remove the incorrect entry.

Good luck,

Urich
  • 0

#13
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
First let me say, THANK YOU URICH!!!!

I can now select which HD I want to boot to upon start up and both will load. Thank you for going out of your way to help me solve my problem.

A new minor problem has arisen though....Now I have 6 different choices when I boot up...I only need the 2 correct ones.

I open the boot.ini and delete the unneeded boot paths as well as rename the working 2 but when I click save I get a message saying

"Cannot create the C:\boot.ini file. Make sure that the path and filename are correct."

Now this is not as serious a problem as before but it is annoying having 6 choices present when only 2 are needed. I was able to edit this file before and save it no problem but now I cannot save the changes I make.

I even clicked save when it first opened and before I changed anything and it still gives me that error message.

Any advice on this?

If you don't I'm still very grateful you were able to resolve my other problem for me...I can't thank you enough!
  • 0

#14
Soldner

Soldner

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts
Maybe this is worth mentioning...if I click save as, and then click save, it tells me that the file already exists with read only attributes...choose a different name....
  • 0

#15
urichjones

urichjones

    Member

  • Member
  • PipPip
  • 45 posts

Maybe this is worth mentioning...if I click save as, and then click save, it tells me that the file already exists with read only attributes...choose a different name....

View Post


Right click the file and go to properties. Uncheck read-only and try to save the file again.

Good Luck.

Urich
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP