Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

RAID 0 Recovery - Help!


  • Please log in to reply

#1
CrockO'Dyle

CrockO'Dyle

    New Member

  • Member
  • Pip
  • 1 posts
I had a bit of a crash :tazz: last week & am trying to recover some data on my RAID Drive. (I recovered my main booting HD okay.) The motherboard has Promise FasTrak 133 (Lite) Raid, which I have configured in RAID 0 using 2 x 80GB Maxtor HDs. These are a single NTFS partition holding about 150GB of data –mostly photos & graphics.

(BTW, Promise doesn't support it's onboard stuff - they just direct you to the MoBo mfr, but the Asus website offers almost nuthin!)

After recovering my main drive, I can boot back to WinXPP okay if I disable the the RAID controller in BIOS. (Or unplugging the suckers) But, if the RAID controller is enabled, Windows hangs at the black screen. (you know, with the blue thingy doing a cylon impression.)
I have tried rebuilding the array from the Fastrak BIOS, but that doesn’t work. I have tried reloading the FastTrak driver too. Safe mode too. Nada.

If I enable the RAID controller, the BIOS check reports that everything is okay with the array. I CAN boot to DOS, but DOS does not recognize the drive – or at least it doesn’t assign it a drive letter. I’m afraid that my DOS skills are very rusty.

I have been successful at getting Ghost to launch from DOS and it even recognizes the RAID drive! I have tried to use Ghost to create an image of the drive’s data. It complains about bad sectors, but eventually it creeps along. But Ghost hangs part way through. (last time I got ~2.5 hrs into an 8hr image.)

I can also launch BART PE-Builder successfully with the RAID controller enabled, but it doesn’t recognize the drive. (Not sure if I have the driver configured right tho.) Funny thing, but Ghost under BART can’t see the drive.

I don’t need all the data, as much of it is multiple versions of the same photos I have been editing.
Ideally I’d find a tool that can fix up the bad sectors on the disk & allow me to view it through Windows.
That said, I’d be happy to simply boot to DOS, view the drive & directory, then revoer as many files as possible with xcopy.

Some options I am considering:
1) A fried recommended using Winternels to try to recover the drive. I’ve never used it before. Any recommendations?
2) Re-install Win XPP to see if that corrects the booting problem. (I’ll probably do this anyway since the integrity of the data on the boot drive is a little questionable.)
3) I have a Promise FastTrak Ultra ATA/66 RAID PCI controller card. I though about installing that in the machine & attaching the drives to it. I think the original crash was due to a power surge that may have affected the MoBo’s onboard controller. BUT, I have no idea if this will ‘see’ the array in the same manner that the other controller set them up.
4) Keep trying to Ghost the drive. But I don’t know why it hangs either. Any way to ‘restart’ a Ghost session from where it left off? Any way to Ghost a single partition in chunks?
5) Some miracle data recovery program??

Any & all help is appreciated!! Thanks. ;)

P.S. My lesson out of this: RAID 1 not RAID 0!

SPECS:
Asus P4533E w/onboard Promise FastTrak133 lite RAID controller (ATA)
P 4 2.2GHz, 1.5GB RAM
100GB Boot drive, Win XPP SP2
RAID 0: 2x80GB Maxtor HDDs


BTW, CPU temp is 34C/93F, MoBo temp is 29C/84F; Voltages: +12v=12.16, +5v=5.241, +3.3v=3.328, and VCore is 1.536
  • 0

Advertisements


#2
BetaGeek

BetaGeek

    New Member

  • Member
  • Pip
  • 1 posts
Bummer that Promise won't support you. What about ASUS?

Also, do you have any hints about where the fault is? Is it a phyical crash of one/both of the drives? Did the controller short out?

Its curious that Ghost can see the drive, but not DOS.

If you are planning to re-install windows anyway, it sounds like a safe option. It might not help anything, but it shouldn't hurt anything either!

I had a similar crash a while ago. Fried my MoBo. Good Luck.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP