Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Medal of Honor Spearhead Crash


  • This topic is locked This topic is locked

#1
mycompsux

mycompsux

    Member

  • Member
  • PipPipPip
  • 108 posts
I have had Medal of Honor Allied Assault Spearhead for two years. Never gave me any problems in terms of crashing. A few days ago, I uninstalled the game, deleted all trace of it and performed a clean install. This involved shutting down all processes running in the background, defragmenting the hard drive and disk cleanup. It installed fine and the two patches installed without a problem. When I go to play the game, I see the usual MOHAAS Console and the screen turns black. It takes an abnormal amount of time for anything to happen. All I see is black and all of a sudden, it goes right back to the desktop. I restart the computer because that is standard procedure when there is a crash and I go back and try to play in Safe Mode and Normal Mode. I still get the same result. This is the first time that this has happened to my game.

Note: All of my drivers are updated and I greatly exceed system requirements.
  • 0

Advertisements


#2
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
does it crash when you go into a game... Ie can you get to the options menu first?
  • 0

#3
mycompsux

mycompsux

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 108 posts
It crashes before anything shows up on screen (EA logo, Quake, Title). A couple seconds after the console's appearance, it crashes to the desktop. I am noticing some lines of characters that I do not remember ever seeing in the MOHAAS Console. I can't get a good look at them because it scrolls down very quickly. My guess is if I knew what those things were saying, the problem can be fixed.
  • 0

#4
MaverickSidewinder

MaverickSidewinder

    Member

  • Member
  • PipPipPip
  • 257 posts
Now, i can suggest one thing:

I have the demo of spearhead and i know what the console looks like. And i know one thing in particular...there is an option that is something like: "Copy"...Follow these steps to copy the console messages:

1. Create a desktop shortcut to the game (if you havent already done that)
2. Start the game once and check where the console appears and see if you can get a glimpse of the copy text button. If you can see it memorize where it is on the screen.
3. Click on the shortcut ONCE, put the mouse where the copy button appears with the console (thats why u had to memorize where it was) now press enter and the game should start bringing up the console, wait for the console to finish displaying everything and right before the game starts press the copy button. When you go back to windows just open wordpad or notepad and go to Edit -> Paste.

I know this is a very unusual way of solving things :) But its the only shot you have to get the text that the console displays.....Wait i though of one more thing...on the right before the screen goes black press the print screen button and it should give you the image of the console displaying the last things...usually errors are reported at the end on the console so you could see them from there.... (to look at your printed screen open paint and go to Edit -> Paste)

:tazz: :) Good Luck!
  • 0

#5
mycompsux

mycompsux

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 108 posts
Here is what was on the console:

--- Common Initialization ---
Medal of Honor Spearhead 2.15 win-x86 Mar 4 2003
----- FS_Startup -----
Current search path:
C:\PROGRA~1\EAGAME~1\MOHAA\mainta\pak5.pk3 (9 files)
C:\PROGRA~1\EAGAME~1\MOHAA\mainta\pak4.pk3 (59 files)
C:\PROGRA~1\EAGAME~1\MOHAA\mainta\pak3.pk3 (311 files)
C:\PROGRA~1\EAGAME~1\MOHAA\mainta\pak2.pk3 (767 files)
C:\PROGRA~1\EAGAME~1\MOHAA\mainta\pak1.pk3 (6969 files)
C:\PROGRA~1\EAGAME~1\MOHAA/mainta
C:\PROGRA~1\EAGAME~1\MOHAA\main\pak6.pk3 (104 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak5.pk3 (259 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak4.pk3 (593 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak3.pk3 (669 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak2.pk3 (4722 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak1.pk3 (772 files)
C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak0.pk3 (11175 files)
C:\PROGRA~1\EAGAME~1\MOHAA/main

----------------------
26409 files in pk3 files
execing default.cfg
execing buildver.cfg
execing menu.cfg
execing newconfig.cfg
execing localize.cfg
Config: unnamedsoldier.cfg
execing configs/unnamedsoldier.cfg
couldn't exec localized.cfg
execing autoexec.cfg
Unknown command "fov"
couldn't exec custom.cfg
...detecting CPU, found Intel Pentium III

------- Input Initialization -------
Initializing DirectInput...
Couldn't set DI coop level
Falling back to Win32 mouse support...
------- Input Initialization Complete ------- 41

Strange, it detects a Pentium III. I have a Pentium 4...

Edited by mycompsux, 26 September 2005 - 10:14 PM.

  • 0

#6
MaverickSidewinder

MaverickSidewinder

    Member

  • Member
  • PipPipPip
  • 257 posts
wierd...

Try downloading the latest drivers for all your video and grafichs cards...and try to figure out something about the CPU detection...its not right that it detects a Pentium III if you have e IV... :tazz: :)
  • 0

#7
ZEUS_GB

ZEUS_GB

    There's no school like old school!

  • Retired Staff
  • 1,650 posts
The game was released before the Pentium 4 came out so the detection program isn't up to date.
  • 0

#8
mycompsux

mycompsux

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 108 posts
The problem has been solved. I believe it was the nVIDIA 78.01 drivers. After updating to 81.85 today, the game worked. Thank you GeekstoGo!
  • 0

#9
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
great to hear that. the 78.1 drivers were very buggy. they caused lots of issues with bf2. enjoy the game!

thanks,
Starjax
  • 0

#10
xPsychox

xPsychox

    New Member

  • Member
  • Pip
  • 1 posts
Err, I have the same problem except that i have a Radeon vid card. I don't want to downgrade my drivers because I have games such as Quake 4 and F.E.A.R.

I exceed the recommended system requirements, so any ideas ?
  • 0

#11
MRPSCR

MRPSCR

    New Member

  • Member
  • Pip
  • 1 posts

Err, I have the same problem except that i have a Radeon vid card. I don't want to downgrade my drivers because I have games such as Quake 4 and F.E.A.R.

I exceed the recommended system requirements, so any ideas ?

I have the same problem you have...I have a radeon 9600 with updated drivers and still can't get spearhead to work....HELP!!!!
  • 0

#12
unique Plugin™

unique Plugin™

    New Member

  • Member
  • Pip
  • 1 posts
Hi there all i found your problem.....

its like this i was playing and i had edited the profile for my nvidia card for mohaa.exe and moh_spearhead.exe and then neither SH or BT would start

right after the console i got a 05f4h blah blah error
after many tries installing old and new drivers. with no success i ran a registry fix after an unistall and reboot
(uninstall, Reeboot, regfix, then reinstall) and reading posts about nHancer
and a ext limit in adanved optios of game profile override settings i decided as id been there just b4 it happed...

that it was me that had caused the poblem.. so....

i realised there may some sort of file or vestage of the nvidia drivers left over from whatever id done causing this fault si i dloaded this, NFR.exe (nasty file remover) a handy dandy nasty file remover for exactly this probled with presets for ATI, NVidia and a few other manufacturers.

Heres the link

http://downloads.gur...b00d7172f230688

so i uninstalled drivers rebooted ran a generic sys registry cleaner of some kind and the ran nfr.exe rebooted installed nvidia drivers and was asked to reeboot by nvidia so i did and upon running the game et voila!!! works again

i needednt have bothered reinstalling 4 cds of MOHAA SH and BT 4 times X( so!! there it is fixed you try

Edited by unique Plugin™, 14 July 2007 - 01:06 AM.

  • 0

#13
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
I'm glad that worked for you. I would like to point out that nfr is no longer supported/updated. Does not work with vista. If you have a need for something like this I recommend: http://drivercleaner.net/

It works very well.

closing out this old thread. If you need further assistance please start a new thread.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP