Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't open encrypted documents


  • Please log in to reply

#1
Stryker06

Stryker06

    Member

  • Member
  • PipPip
  • 39 posts
I encrypted my important documents, had to re-install Windows, now OpenOffice won't let me open those documents anymore. Tried to un-encrypt the documents
But that was no success either. :tazz: Is it now impossible to access my important documents? that would be a disaster :)
Advice appreciated.
  • 0

Advertisements


#2
Guse

Guse

    Visiting Staff

  • Member
  • PipPipPip
  • 624 posts
I'm not promising this will work, but it's supposed to.

First off, I'm assuming you're using Windows XP's EFS (encrypted file system) for the encryption. If I'm wrong, stop here and tell me that.


Now, log onto the computer as an administrator. Preferrably, with the administrator account (but any account set up as an admin should do it). If you don't have access to one, let me know.

Navigate to the folder that's encrypted and take ownership of the folder:
  • Right-click the target folder and choose properties, this will bring up the %foldername% Properties Window.
  • Select the Security tab and click Advanced. This will bring up the Advanced Security Settings for %foldername% window.
  • Select the Owner tab.
  • Single-click the account you'd like to be the owner of the file (like "Administrators")
  • Make sure that the "Replace Owner on Subcontainers and Objects" box is checked
  • Click Apply
This will probably take a while. Just wait it out.

When it's done replacing ownership, click OK once to return to the %foldername% Properties window.

Now, select the General tab, click Advanced and uncheck the box next to Encrypt Contents to Secure Data. Again, this will probably take a while, wait it out.

When it's done, you should have removed the encryption on the folder, allowing you to open the documents as normal this time.

Edited by Guse, 28 September 2005 - 10:11 AM.

  • 0

#3
Stryker06

Stryker06

    Member

  • Topic Starter
  • Member
  • PipPip
  • 39 posts
Hi Guse, thanks for your reply
I thought methoed might do the trick, but it didn't :tazz:
The thing is, the folder is not encrypted, but the documents inside the folder are. When I look who the owners are it says Administrators and me, I have admin rights, all the rights and powers, yet I get access is denied when trying to open a document. Trying to un-encrypt the doc only give me an "unable to do..." or other message. [bleep]!
Got any more ideas? don't know why I encrypted my docs in the first [bleep] place since I'm the only one who's ever uses my computer.
  • 0

#4
Guse

Guse

    Visiting Staff

  • Member
  • PipPipPip
  • 624 posts
Another option may be to repeat the steps I gave you with a single encrypted file first, instead of the folder.

As for the Owners being you and the admins, there can only be one. You're probably looking at the large white box that says "Change Owner to", which tells you what users can be owners. There's a smaller text box above that which says "Current Owner of this Item". To change the owner, select the name below that you want to use (in your case, the Administrators account) and click Apply.

Edited by Guse, 29 September 2005 - 08:15 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP