Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

GeForce 6600 Vid Card & World of Warcraft


  • Please log in to reply

#1
MikeV53

MikeV53

    Member

  • Member
  • PipPip
  • 19 posts
Just purchased an Nvide GeForce 6600 video card for my pc and installed the drivers that came with the card. When I opened World of Warcraft the screen pixalated and then the logon screen froze. I uninstalled the drivers and installed a different driver version. The same thing happened. Tried 4 different driver versions and still the same thing. I don't know what else to do.

I have a Soyo KT600 Dragon v2.0 Socket A Motherboard with a AMD Athlon XP3000+ Socket A CPU Barton Core 333FSB processor and 512mb of RAM. I am running Windows XP Professional.

ANy help you can give me will be greatly appreciated.
  • 0

Advertisements


#2
MikeV53

MikeV53

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
Anyone please help me out here I spent like 130 bucks on this video card and it wont work for the one game i bought it for.
  • 0

#3
MikeV53

MikeV53

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
anyone help me out here i still cant figure out what is problem is still getting garbled screen when i log into wow
  • 0

#4
MikeV53

MikeV53

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
come on guys a lil help would be appreciated here i dont want to have to buy another video card again
  • 0

#5
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Perhaps the graphics card is faulty?
  • 0

#6
MikeV53

MikeV53

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
That's what I'm thinking. I put the old card (PNY GeForce MX4000 128MB AGP) back in and it works fine in W.O.W. I've got the extra cash I'm going to try the new GEForce 6800 card. :tazz:
  • 0

#7
uafx

uafx

    New Member

  • Member
  • Pip
  • 1 posts
I have the same problem with my new AOpen Aeolus 6600 (with nVidia 6600).
The screen freezes not only in World of Warcraft, but also in "Second Sight", the game that came along with the graphics card.

The problem exists with all driver versions I tried (76.44, 77.72 and 78.01).
Is this a common problem, or is my HW defect as well as yours? Have you found any solution in the meantime?
  • 0

#8
MikeV53

MikeV53

    Member

  • Topic Starter
  • Member
  • PipPip
  • 19 posts
I have done everything short of reinstalling the OS. I am actually sending the card back to the place I purchased it from today, to see if I can get a replacement card. Will keep posting if anything else pops up. Thanks
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP